Bug 169988 - vsFTPd Virtual Users incompatible with pam_userdb.so
vsFTPd Virtual Users incompatible with pam_userdb.so
Status: CLOSED DUPLICATE of bug 164418
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 01:53 EDT by Anthony Baratta
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 04:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anthony Baratta 2005-10-06 01:53:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
When following the documentation outlined at 

ftp://vsftpd.beasts.org/users/cevans/untar/vsftpd-2.0.3/EXAMPLE/VIRTUAL_USERS/README

regarding setup of Virtual Users. Upon an attempted (which should be a successful login) vsFTPd throws the following error:

500 OOPS: priv_sock_get_result

There are dozens of reports of the same error with FC 4, vsFTPd and PAM. The dominate "solution" is to use a pam_userdb.so file from FC 3. Apparently other's have run PAM in debug mode and it's reporting a successful login, but vsFTPd is not acting on it correctly. 

No errors are logged by vsFTPd.




Version-Release number of selected component (if applicable):
vsftpd-2.0.3-1, pam-0.79-8

How reproducible:
Always

Steps to Reproduce:
1. Fresh FC 4 install.

2. Follow virtual users setup here:
ftp://vsftpd.beasts.org/users/cevans/untar/vsftpd-2.0.3/EXAMPLE/VIRTUAL_USERS/README

3. Start vsFTPd service and attempt to login.
  

Actual Results:  # ftp localhost
Connected to foo.com.
220 foo.com FTP service.
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (localhost:root): mario
331 Please specify the password.
Password:
500 OOPS: priv_sock_get_result
Login failed.
421 Service not available, remote server has closed connection


Expected Results:  Successful login.

Additional info:

Pam vsFTPd file:

#%PAM-1.0
auth required /lib/security/pam_userdb.so db=/etc/vsftpd/user_db/login
account required /lib/security/pam_userdb.so db=/etc/vsftpd/user_db/login

Command used to make db file:
db_load -T -t hash -f login.txt ./login.db

vsFTPd Config file (partial):

# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
nopriv_user=ftp
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
chroot_local_user=YES

# PAM Config
pam_service_name=vsftpd
userlist_enable=YES

#enable for standalone mode
listen=YES
tcp_wrappers=YES

#Virtual Users
guest_enable=YES
guest_username=ftp
user_config_dir=/etc/vsftpd/user_config

User Config File:
local_root=/web/sites/foo.com

Owner of /web/sites/foo.com
ftp:apache
Comment 1 Radek Vokal 2005-10-06 04:51:41 EDT
This was fixed in pam update

*** This bug has been marked as a duplicate of 164418 ***

Note You need to log in before you can comment on or make changes to this bug.