Bug 164418 - pam_userdb not working
Summary: pam_userdb not working
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
: 164680 169988 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-27 20:01 UTC by Jakob Hirsch
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: pam-0.79-9.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 10:52:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jakob Hirsch 2005-07-27 20:01:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
pam_userdb stopped working after upgrade vom fc3 to fc4.


Version-Release number of selected component (if applicable):
pam-0.79-9.1

How reproducible:
Always

Steps to Reproduce:
1. setup /some/text/file with username\npassword 
2. run db_load -T -t hash -f /some/text/file /some/text/file.db
3. configure pam to use it: 
auth            required        pam_userdb.so db=/some/text/file
  

Actual Results:  login fails

Expected Results:  login should succeed

Additional info:

pam_userdb can e.g. be used with vsftpd. 

contents of /etc/pam.d/vsftpd:

auth            required        pam_userdb.so debug db=/etc/vsftpd_login
account         required        pam_permit.so
session         required        pam_permit.so


with pam_userdb.so from pam-0.79-9.1:

ymmv pam_userdb[20219]: Verify user `plonk' with password `samplepassword'
ymmv pam_userdb[20219]: password in database is [0x835d728]`samplepassword', len is 14

after replacing it with the FC3 one from pam-0.77-66.2.i386.rpm it works again:

pam_userdb[20204]: Verify user `plonk' with password `samplepassword'
pam_userdb[20204]: password in database is [0x8356928]`samplepassword', len is 14
pam_userdb[20204]: user 'plonk' granted acces


while testing, I also saw garbage added to the password:
password in database is [0x*******]`********^P', len is 8
password in database is [0x*******]`*************ogin.db', len is 13

Comment 1 Tomas Mraz 2005-07-29 10:52:05 UTC
Fixed in RAWHIDE and FC4 updates.


Comment 2 Jakob Hirsch 2005-07-29 12:14:19 UTC
Latest version in FC4 updates (and testing) is pam-0.79-9.1, which the report
above is about.
pam-0.80-5 from rawhide works, though. Thanks.

Comment 3 Tomas Mraz 2005-07-29 12:26:49 UTC
It's not yet pushed out. (See the Fixed in field for the version which is fixed.)


Comment 4 Tomas Mraz 2005-08-08 12:38:06 UTC
*** Bug 164680 has been marked as a duplicate of this bug. ***

Comment 5 Radek Vokal 2005-10-06 08:51:59 UTC
*** Bug 169988 has been marked as a duplicate of this bug. ***

Comment 6 Anthony Baratta 2005-10-06 17:29:59 UTC
FYI...

I grabbed a copy of pam_userdb.so v0.79-9.5 from updates for FC4 and that works.



Note You need to log in before you can comment on or make changes to this bug.