Bug 170005 - Installer exits abnormally after clicking next in choose partition method screen
Installer exits abnormally after clicking next in choose partition method screen
Status: CLOSED DUPLICATE of bug 170003
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 08:51 EDT by Jackson Wright
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 10:27:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jackson Wright 2005-10-06 08:51:25 EDT
Description of problem:
Every time I run the installer and get to the point where I choose whether or 
not to automatically partition the disk or use Disk Druid, I hit automatically 
and hit next, and it crashes.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.Turn on Computer.
2.Boot linux from the yaboot thing.
3.run anaconda
4.click through dialog boxes
5.beat hands on desk in frustration
6.reboot...try again
  
Actual results:
My installer exits abnormally after flashing a bug message.

Expected results:
It should continue the installation process.

Additional info:
Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 873 in nextClicked
       self.dispatch.goto.Next()
File "/usr/lib/anaconda/dispatch.py", line 174 in gotoNext
       self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242 in moreStep
       rc=apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/partitioning.py", line 54 in partitionObjectsInitialize
      partitions.setFromDisk(diskset)
File "/usr/lib/anaconda/partitions.py", line 108 in setFromDisk
      ptype=partedUtils.get_partition_file_system_type(part)
File "/usr/lib/anaconda/partedUtils.py", line 140, in 
get_partition_file_system_type
      elif(part.get_flag(partd.PARTITION_BOOT) == 1 and
Attribute Error: "NoneType" object has no attribute 'name'
Comment 1 Chris Lumens 2005-10-06 10:27:52 EDT

*** This bug has been marked as a duplicate of 170003 ***

Note You need to log in before you can comment on or make changes to this bug.