Bug 1700882 - [RFE][BACKPORT] Cinder RBD multi-attach on OSP13
Summary: [RFE][BACKPORT] Cinder RBD multi-attach on OSP13
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: z8
: 13.0 (Queens)
Assignee: Jon Bernard
QA Contact: Tzach Shefi
Tana
URL:
Whiteboard:
: 1728327 (view as bug list)
Depends On: 1230807 1624971 1728323 1790753
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-17 14:37 UTC by Gregory Charot
Modified: 2020-01-14 05:55 UTC (History)
11 users (show)

Fixed In Version: openstack-cinder-12.0.7-5.el7ost
Doc Type: Technology Preview
Doc Text:
This update expands the Block Storage service multi attach feature to the Ceph RBD driver.
Clone Of:
Environment:
Last Closed: 2019-09-03 16:54:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2627 0 None None None 2019-09-03 16:54:29 UTC

Description Gregory Charot 2019-04-17 14:37:24 UTC
Description of problem:

We are backporting Cinder Multi attach on OSP13 tech preview. Each driver caps need to be backported as well.

There are enough customer's demands to backport Ceph RBD multi-attach to OSP13.

Version-Release number of selected component (if applicable):

13

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 9 Eric Harney 2019-07-09 17:16:33 UTC
*** Bug 1728327 has been marked as a duplicate of this bug. ***

Comment 10 Gregory Charot 2019-07-10 09:45:07 UTC
The missing patch got merged upstream and we can now proceed with the 13 backport with a z8 target which should be available around end of august / september timeframe.

Hot fixes are meant to provides urgent fixes not feature backports.

Comment 24 Tzach Shefi 2019-08-20 09:12:45 UTC
Not landed yet, P1 ->  13  2019-08-13.1

Produced a prefixed-in of:
openstack-cinder-12.0.7-4.0.bz1705563.el7ost.noarch 

Waiting for newer build.

Comment 28 Tzach Shefi 2019-08-21 12:02:10 UTC
Verified on:
openstack-cinder-12.0.7-5.el7ost

Ran full manual test plan, basic work flow is mostly OK. 

Found 3 bugs: 
RO volume aren't RO on all instance, this is a problem but it's a backport TP plus I don't expect many MA RO volumes OK to pass. 
https://bugzilla.redhat.com/show_bug.cgi?id=1744099   

Clone of a known MA osp15 bz:
https://bugzilla.redhat.com/show_bug.cgi?id=1744112

Openstack client attach bz:
https://bugzilla.redhat.com/show_bug.cgi?id=1744051 

Despite all these 3, the first being the most serious one
IMHO it's still OK to verify as tech preview backport.

Comment 33 errata-xmlrpc 2019-09-03 16:54:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2627


Note You need to log in before you can comment on or make changes to this bug.