Bug 1702083 - [V2V][Regression] Migration plan CSV import validation not working if file contains empty/archived/orphan/invalid VM name
Summary: [V2V][Regression] Migration plan CSV import validation not working if file co...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: V2V
Version: 5.10.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.4
Assignee: Fabien Dupont
QA Contact: Yadnyawalk Tale
Red Hat CloudForms Documentation
URL:
Whiteboard: v2v
Depends On: 1699343
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-22 22:17 UTC by Satoe Imaishi
Modified: 2019-05-21 05:47 UTC (History)
4 users (show)

Fixed In Version: 5.10.4.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1699343
Environment:
Last Closed: 2019-05-21 05:46:56 UTC
Category: ---
Cloudforms Team: V2V
Target Upstream Version:


Attachments (Terms of Use)
fixed_proof.png (192.73 KB, image/png)
2019-04-25 07:49 UTC, Yadnyawalk Tale
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1247 None None None 2019-05-21 05:47:04 UTC

Comment 3 CFME Bot 2019-04-24 19:47:05 UTC
New commit detected on ManageIQ/manageiq-v2v/hammer:

https://github.com/ManageIQ/manageiq-v2v/commit/22259dd8cbe2812e749ef99163653492dda9467c
commit 22259dd8cbe2812e749ef99163653492dda9467c
Author:     Milan Zázrivec <mzazrivec@redhat.com>
AuthorDate: Tue Apr 16 10:44:04 2019 -0400
Commit:     Milan Zázrivec <mzazrivec@redhat.com>
CommitDate: Tue Apr 16 10:44:04 2019 -0400

    Merge pull request #932 from mturley/bz1699343-csv-validation-fix

    [BZ#1699343] Fix regression in CSV validation with invalid rows

    (cherry picked from commit 8bb740d7f05259671d141257ebb7477c3ad9fce1)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1702083

 app/javascript/react/screens/App/Overview/screens/PlanWizard/components/PlanWizardVMStep/__tests__/helpers.test.js | 4 +
 app/javascript/react/screens/App/Overview/screens/PlanWizard/components/PlanWizardVMStep/helpers.js | 3 +
 2 files changed, 7 insertions(+)

Comment 4 Yadnyawalk Tale 2019-04-25 07:49:44 UTC
Created attachment 1558491 [details]
fixed_proof.png

Fixed! Verified in 5.10.4.0.20190424160602_acb6009

Comment 6 errata-xmlrpc 2019-05-21 05:46:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1247


Note You need to log in before you can comment on or make changes to this bug.