Bug 17031 - rev doesn't work
Summary: rev doesn't work
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
: 17671 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-28 12:54 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 04:37:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-28 12:54:58 UTC
[after a fresh install of pinstripe]

if i type 
> echo "one two three" | rev

the result is "t eno", instead of "eerht owt eno"
it seems to be a problem with the wide chars functions (wcslen ..)

Comment 1 Need Real Name 2000-09-19 04:37:57 UTC
*** Bug 17671 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Johnson 2000-10-09 16:25:54 UTC
I can't reproduce your problem:

    bash$ echo "one two three" | rev
    eerht owt eno
    bash$ rpm -qf /usr/bin/rev
    util-linux-2.10m-12
    bash$ rpm -q glibc
    glibc-2.1.94-2



Note You need to log in before you can comment on or make changes to this bug.