Bug 170662 - up2date mistakenly flags existing package for update
up2date mistakenly flags existing package for update
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-13 13:12 EDT by Bill Muller
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 17:36:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Muller 2005-10-13 13:12:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)

Description of problem:
This appears to be similar to Bugzilla Bug 102522 for which no resolution has been identified and there has been no activity on since 2005-01-07.  If this is ultimately classified as a duplicate of 102522 then 102522 should be reexamined rather than simply left as assigned with no activity.

When running up2date on a freshly loaded RHELWS3 U6 system up2date mistakenly identifies openoffice.org-1.1.2-28.2.0.EL3 as requiring an update.  Since this is the same version of the package that is already installed on the system up2date terminates with the message:

Testing package set / solving RPM inter-dependencies...
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package openoffice.org-1.1.2-28.2.0.EL3 is already installed

Version-Release number of selected component (if applicable):
up2date-4.4.44-3

How reproducible:
Didn't try


Additional info:
Comment 1 Bill Muller 2005-10-13 13:22:34 EDT
I forgot to mention that when I login to my RHN account and examine this system
the openoffice.org-1.1.2-28.2.0.EL3 package is not identified on the "Upgradable
Packages" page.  All the other packages identified by up2date are listed on the
RHN page.
Comment 2 Suzanne Hillman 2005-10-13 14:23:20 EDT
This is a freshly loaded system? Then the reason that others have had this
problem may not apply, but it's worth checking anyway. Another person who had
problems similar to this determined that somehow multiple versions of the same
rpm were installed, causing this problem. Can you check if there are multiple
openoffice.org rpms installed right now, via 'rpm -q openoffice.org'?
Comment 3 Bill Muller 2005-10-13 14:37:01 EDT
Yes, this is a freshly loaded system.

Running 'rpm -q openoffice.org' returned the single line:
openoffice.org-1.1.2-28.2.0.EL3

What is especially puzzling is that the openoffice.org package does not show up
on RHN for this system.
Comment 4 Suzanne Hillman 2005-10-13 15:30:10 EDT
Hmm. I'm fairly sure that you can get rhn to tell a machine to upgrade itself,
although I've never myself had reason to test this. Since the package which is
being strange isn't showing up on RHN for that system, what happens if you use
RHN to tell the machine to upgrade itself?
Comment 5 Suzanne Hillman 2005-10-13 15:31:08 EDT
'Nother thing I might try, out of curiosity, is removing the offending rpm, and
reinstalling it. That may or may not be something you're willing to do, I realize.
Comment 6 Bill Muller 2005-10-13 16:12:59 EDT
I have just done the following:

1) rpm -e openoffice.org-style-gnome \
          openoffice.org-libs \
          openoffice.org-i18n \
          openoffice.org

2) up2date --nox -p

3) rpm -ihv openoffice.org-style-gnome-1.1.0-16.9.EL.i386.rpm \
            openoffice.org-libs-1.1.2-28.2.0.EL3.i386.rpm \
            openoffice.org-i18n-1.1.2-28.2.0.EL3.i386.rpm \
            openoffice.org-1.1.2-28.2.0.EL3.i386.rpm

4) up2date --nox -p

5) up2date --nox -u  -d

The end result was the same, up2date attempted to update the openoffice.org package.


As for using RHN to tell systems to update I do that with some of my systems and
it works quite well.  The reason I don't want to use that mechanism with this
system is that I am working on a procedure to create custom installation media
that has the latest set of packages as of a specific date.  I could also
configure up2date to skip this package but then what happens when a valid update
for openoffice does come out?
Comment 7 Bill Muller 2005-10-21 18:51:43 EDT
It has been over a week since anyone has responded, what's the story?  Is this a
bug?  WHere do I go from here?
Comment 8 Suzanne Hillman 2005-10-24 10:33:11 EDT
Well, if this is something for which you have urgency, you would be best 
off going through our support mechanism. In order to file a support issue, 
please either contact Red Hat's Technical Support line at 888-GO-REDHAT 
or file a web ticket at http://www.redhat.com/apps/support/.  Bugzilla 
is not an official support channel, has no response guarantees, and may 
not route your issue to the correct area to assist you.  Using the 
official support channels above will guarantee that your issue is 
handled appropriately and routed to the individual or group which can 
best assist you with this issue and will also allow Red Hat to track 
the issue, ensuring that any applicable bug fix is included in all 
releases and is not dropped from a future update or major release.
Comment 9 Bill Muller 2005-10-24 12:19:13 EDT
Thanks for the response.  I'll put a call in through developer support.
Comment 11 Bill Muller 2005-11-03 17:36:47 EST
The problem has been tracked down to an extraneous package being included in U6.
 Package openoffice.org-1.1.2-28.2.0.EL3 obsoletes openoffice.org-style-gnome
but openoffice.org-style-gnome is still included in the distribution.  After
removing the obsolete package from my system up2date functions properly.

Note You need to log in before you can comment on or make changes to this bug.