Bug 1707223 - fedpkg co --branches fails with 1.37
Summary: fedpkg co --branches fails with 1.37
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedpkg
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: cqi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1709674 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-07 05:38 UTC by Mamoru TASAKA
Modified: 2019-05-26 01:40 UTC (History)
9 users (show)

Fixed In Version: fedpkg-1.37-1.fc28 fedpkg-1.37-1.fc29 fedpkg-1.37-1.el6 fedpkg-1.37-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 00:59:30 UTC


Attachments (Terms of Use)

Description Mamoru TASAKA 2019-05-07 05:38:52 UTC
Description of problem:
As written in Summary, "fedpkg co --branches" (i.e. --branches option) does not work with 1.37-1.fc30


Version-Release number of selected component (if applicable):
fedpkg-1.37-1.fc30

How reproducible:
100%

Steps to Reproduce:
1. fedpkg co --branches oniguruma
2.
3.

Actual results:
$ fedpkg co --branches oniguruma
Cloning into bare repository '/home/mtasaka/rpmbuild/fedora-specific/oniguruma/rpkg.git'...
remote: Counting objects: 306, done.
remote: Compressing objects: 100% (239/239), done.
remote: Total 306 (delta 135), reused 114 (delta 55)
Receiving objects: 100% (306/306), 43.25 KiB | 328.00 KiB/s, done.
Resolving deltas: 100% (135/135), done.
Could not execute clone: [Errno 2] No such file or directory: '/home/mtasaka/rpmbuild/fedora-specific/oniguruma/rpkg.git/.git/info/exclude'

And as the result, there is no oniguruma/ directory


Expected results:
As with fedpkg-1.36-2.fc30 :

$ fedpkg co --branches oniguruma
Cloning into bare repository '/home/mtasaka/rpmbuild/fedora-specific/oniguruma/rpkg.git'...
remote: Counting objects: 306, done.
remote: Compressing objects: 100% (239/239), done.
remote: Total 306 (delta 135), reused 114 (delta 55)
Receiving objects: 100% (306/306), 42.94 KiB | 278.00 KiB/s, done.
Resolving deltas: 100% (135/135), done.
$ ls -al oniguruma/
合計 112
drwx------. 28 mtasaka mtasaka 4096  5月  7 14:33 .
drwx------. 56 mtasaka mtasaka 4096  5月  7 14:33 ..
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 epel7
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f10
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f11
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f12
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f13
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f14
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f15
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f16
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f17
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f18
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f19
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f20
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f21
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f22
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f23
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f24
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f25
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f26
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f27
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f28
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f29
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f30
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f7
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f8
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 f9
drwx------.  3 mtasaka mtasaka 4096  5月  7 14:33 master



Additional info:

Comment 1 Todd Zullinger 2019-05-08 02:00:27 UTC
I saw this mentioned in IRC and was curious.  I took a look and filed https://pagure.io/rpkg/pull-request/444 with a fix for this.  It lacks tests, so it might need some further work before it's merged.  (I hope someone else has the time to add if they're considered a blocker -- but AFAICT there aren't tests for the --branches option at all, or this would have been caught earlier.)

Comment 2 Ondřej Nosek 2019-05-09 15:55:48 UTC
Mamoru & Todd, thanks.
I used your suggested patch, added proper tests and preparing the update.
It will be released in rpkg-1.58-2.
Fedora rawhide version is already available.

Comment 3 Fedora Update System 2019-05-10 13:54:58 UTC
fedpkg-1.37-1.fc28 rpkg-1.58-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e4359dc92a

Comment 4 Fedora Update System 2019-05-10 13:55:03 UTC
fedpkg-1.37-1.fc28 rpkg-1.58-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e4359dc92a

Comment 5 Fedora Update System 2019-05-10 14:02:55 UTC
rpkg-1.58-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-38f05e9daf

Comment 6 Fedora Update System 2019-05-10 14:06:24 UTC
fedpkg-1.37-1.el6 rpkg-1.58-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-309ad8482c

Comment 7 Fedora Update System 2019-05-10 14:06:29 UTC
fedpkg-1.37-1.el6 rpkg-1.58-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-309ad8482c

Comment 8 Fedora Update System 2019-05-10 14:08:13 UTC
fedpkg-1.37-1.el7 rpkg-1.58-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-ef52f1c4c0

Comment 9 Fedora Update System 2019-05-10 14:08:17 UTC
fedpkg-1.37-1.el7 rpkg-1.58-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-ef52f1c4c0

Comment 10 Fedora Update System 2019-05-10 14:10:13 UTC
fedpkg-1.37-1.fc29 rpkg-1.58-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b5d0735782

Comment 11 Fedora Update System 2019-05-10 14:10:18 UTC
fedpkg-1.37-1.fc29 rpkg-1.58-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b5d0735782

Comment 12 Fedora Update System 2019-05-11 02:10:44 UTC
rpkg-1.58-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-38f05e9daf

Comment 13 Fedora Update System 2019-05-11 02:39:59 UTC
fedpkg-1.37-1.el6, rpkg-1.58-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-309ad8482c

Comment 14 Fedora Update System 2019-05-11 03:12:00 UTC
fedpkg-1.37-1.el7, rpkg-1.58-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-ef52f1c4c0

Comment 15 Fedora Update System 2019-05-11 04:23:59 UTC
fedpkg-1.37-1.fc29, rpkg-1.58-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b5d0735782

Comment 16 Fedora Update System 2019-05-11 23:07:11 UTC
fedpkg-1.37-1.fc28, rpkg-1.58-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e4359dc92a

Comment 17 Mamoru TASAKA 2019-05-13 04:18:02 UTC
Confirmed that rpkg-1.58-2.fc30 fixed this issue, thank you.

Comment 18 Fedora Update System 2019-05-14 00:59:30 UTC
rpkg-1.58-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Lubomír Sedlář 2019-05-14 07:18:17 UTC
*** Bug 1709674 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2019-05-25 01:10:36 UTC
fedpkg-1.37-1.fc28, rpkg-1.58-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2019-05-25 03:34:47 UTC
fedpkg-1.37-1.fc29, rpkg-1.58-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2019-05-26 01:05:10 UTC
fedpkg-1.37-1.el6, rpkg-1.58-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2019-05-26 01:40:25 UTC
fedpkg-1.37-1.el7, rpkg-1.58-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.