Bug 1709674 - Fails to clone with branches
Summary: Fails to clone with branches
Keywords:
Status: CLOSED DUPLICATE of bug 1707223
Alias: None
Product: Fedora
Classification: Fedora
Component: fedpkg
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: cqi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-14 07:02 UTC by Milan Crha
Modified: 2019-05-14 07:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 07:18:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Milan Crha 2019-05-14 07:02:30 UTC
This is with:

$ rpm -q fedpkg
fedpkg-1.37-1.fc30.noarch

Fails to clone with -B:

$ fedpkg clone --anonymous -B glib2
Cloning into bare repository '/home/user/fedora/glib2/rpkg.git'...
remote: Counting objects: 2961, done.
remote: Compressing objects: 100% (2212/2212), done.
remote: Total 2961 (delta 1243), reused 1583 (delta 621)
Receiving objects: 100% (2961/2961), 452.58 KiB | 527.00 KiB/s, done.
Resolving deltas: 100% (1243/1243), done.
Could not execute clone: [Errno 2] No such file or directory: '/home/user/fedora/glib2/rpkg.git/.git/info/exclude'

Removing the -B makes it work:

$ fedpkg clone --anonymous glib2
Cloning into 'glib2'...
remote: Counting objects: 2961, done.
remote: Compressing objects: 100% (2212/2212), done.
remote: Total 2961 (delta 1245), reused 1583 (delta 621)
Receiving objects: 100% (2961/2961), 441.95 KiB | 511.00 KiB/s, done.
Resolving deltas: 100% (1245/1245), done.

Comment 1 Milan Crha 2019-05-14 07:04:22 UTC
Running the same command (with -B) for example with fedpkg-1.32-1.fc28.noarch works just fine.

Comment 2 Lubomír Sedlář 2019-05-14 07:18:17 UTC
Please try with latest python3-rpkg installed. 1.58-2 should fix this issue.

*** This bug has been marked as a duplicate of bug 1707223 ***

Comment 3 Milan Crha 2019-05-14 07:36:04 UTC
(In reply to Lubomír Sedlář from comment #2)
> Please try with latest python3-rpkg installed. 1.58-2 should fix this issue.

Thanks, it survives with it. My fault I didn't try to update the machine first, I thought (incorrectly) there would be nothing since my yesterday update. I'm sorry about that. The same that I missed the already filled bug.


Note You need to log in before you can comment on or make changes to this bug.