Bug 170762 - Remove hp device manager from menus
Remove hp device manager from menus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 192794 (view as bug list)
Depends On:
Blocks: Yellowpad
  Show dependency treegraph
 
Reported: 2005-10-14 09:56 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.9.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-14 11:07:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2005-10-14 09:56:28 EDT
We don't give free ad space to HP on our menus...

Also, the hplip init scripts should try to be good citizens and write a single
line like all other scripts do.
Comment 1 Tim Waugh 2005-10-14 10:21:12 EDT
Should we not ship the desktop file?

I'll try to clean up the init script output.
Comment 2 Matthias Clasen 2005-10-14 12:07:29 EDT
We can ship the desktop file, but it should not be visible in the menus by
default. (Hidden=true, I think)
Comment 3 Tim Waugh 2005-10-14 14:09:57 EDT
Thanks.  Fixed in CVS.
Comment 4 Tim Waugh 2006-05-23 04:11:08 EDT
*** Bug 192794 has been marked as a duplicate of this bug. ***
Comment 5 Stewart Adam 2006-09-07 17:07:29 EDT
Why should it be disabled by default? hplip-toolbox is a good, valid tool that
can be used to clean an HP printer's cartriges and such, along with monitoring
printer status and cancelling jobs.
Comment 6 Bernard Johnson 2007-03-23 17:28:38 EDT
(In reply to comment #0)
> We don't give free ad space to HP on our menus...
> 

Matthias,

What do you consider advertising here?


Comment 7 Matthias Clasen 2007-03-26 23:27:08 EDT
The comment referred to the icon.
Comment 8 Bernard Johnson 2007-03-27 02:08:19 EDT
But if I understand your comments here, even if the icon was
changed/updated/replaced, you would still not want the program to appear on the
menu:

http://permalink.gmane.org/gmane.linux.redhat.fedora.devel/51665
Comment 9 Bernard Johnson 2007-03-27 02:10:15 EDT
Tim,

Would you mind at least updating the .desktop file so that the Categories are
right?  As it stands, you not only have to change it from a hidden entry, you
have to change it to a valid Category to have it display.
Comment 10 Matthias Clasen 2007-03-27 13:02:18 EDT
If you replace Hidden=true by NoDisplay=true, the darn thing will show up in
menu editors so people have an easier way to get it back in their menus.

Also, "Utility" is really not the right category for this. Something that calls
itself a manager fits much better under "System".
Comment 11 Tim Waugh 2007-04-03 12:30:53 EDT
(In reply to comment #10)
I've done that now in CVS.

Note You need to log in before you can comment on or make changes to this bug.