Bug 1707712 - liberation-fonts.noarch should not Provides or Obsoletes liberation-narrow fonts
Summary: liberation-fonts.noarch should not Provides or Obsoletes liberation-narrow fonts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liberation-fonts
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1720451 1751699 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-08 07:41 UTC by Jens Petersen
Modified: 2019-09-13 05:01 UTC (History)
20 users (show)

Fixed In Version: liberation-fonts-2.00.5-3.fc30 liberation-fonts-2.00.5-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-30 14:20:48 UTC


Attachments (Terms of Use)

Description Jens Petersen 2019-05-08 07:41:28 UTC
Description of problem:
This may be due to unclear wording in the Packaging Guidelines
but liberation-fonts should not Provides or Obsoletes liberation-narrow-fonts.

In fact is basically to install liberation-narrow-fonts in Fedora because of this. ;-)

The Obsoletes made sense before liberation-narrow-fonts was reintroduced to Fedora (except the upperbound is far to high).

How reproducible:
100%

Steps to Reproduce:
1. Try to install liberation-narrow-fonts
# dnf install liberation-narrow-fonts

Actual results:
liberation-fonts gets installed

Expected results:
liberation-narrow-fonts

Additional info:
https://docs.fedoraproject.org/en-US/packaging-guidelines/#renaming-or-replacing-existing-packages

"If a package supersedes/replaces an existing package without being a sufficiently compatible replacement as defined above, use only the Obsoletes: line from the above example."

Comment 1 Kevin Kofler 2019-08-21 21:05:21 UTC
*** Bug 1720451 has been marked as a duplicate of this bug. ***

Comment 2 Kevin Kofler 2019-08-21 21:06:37 UTC
Ping? This was finally fixed in Rawhide (and F31, because it was fixed in Rawhide before F31 branched), but it is still broken in F29 and F30!

Comment 3 Kevin Kofler 2019-08-21 21:09:41 UTC
As a provenpackager, I can push updates fixing this, do you want me to do that? And if yes, on F29, shall I fix only the Obsoletes/Provides or upgrade to 2.00.5 as shipped on F30 and F31? (F30 has 2.00.5-2 already and is only missing the fix, which is in 2.00.5-3.)

Comment 4 Fedora Update System 2019-08-23 11:24:21 UTC
FEDORA-2019-e569dfd0c5 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e569dfd0c5

Comment 5 Fedora Update System 2019-08-23 11:24:21 UTC
FEDORA-2019-43b854e54a has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-43b854e54a

Comment 6 Kevin Kofler 2019-08-23 11:35:08 UTC
Thanks!

Comment 7 Fedora Update System 2019-08-24 01:36:17 UTC
liberation-fonts-2.00.5-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e569dfd0c5

Comment 8 Fedora Update System 2019-08-24 04:32:42 UTC
liberation-fonts-2.00.5-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-43b854e54a

Comment 9 Bas Mevissen 2019-08-29 13:29:46 UTC
$ rpm -qa | grep liberation-
liberation-mono-fonts-2.00.5-3.fc30.noarch
liberation-sans-fonts-2.00.5-3.fc30.noarch
liberation-fonts-2.00.5-3.fc30.noarch
liberation-fonts-common-2.00.5-3.fc30.noarch
liberation-narrow-fonts-1.07.6-1.fc30.noarch
liberation-serif-fonts-2.00.5-3.fc30.noarch
[bas@cloud Downloads]$ sudo dnf upgrade
Fedora 30 openh264 (From Cisco) - x86_64                                                            478  B/s | 542  B     00:01    
Fedora 30 - x86_64 - Test Updates                                                                    34 kB/s |  23 kB     00:00    
Fedora 30 - x86_64 - Updates                                                                         36 kB/s |  24 kB     00:00    
Fedora 30 - x86_64                                                                                   35 kB/s |  24 kB     00:00    
(...)
Dependencies resolved.

 Problem: cannot install both liberation-fonts-1:2.00.5-1.fc30.noarch and liberation-fonts-1:2.00.5-3.fc30.noarch
  - cannot install the best update candidate for package liberation-narrow-fonts-1.07.6-1.fc30.noarch
  - cannot install the best update candidate for package liberation-fonts-1:2.00.5-3.fc30.noarch
====================================================================================================================================
 Package                             Architecture              Version                              Repository                 Size
====================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 liberation-fonts                    noarch                    1:2.00.5-1.fc30                      fedora                    8.0 k

Transaction Summary
====================================================================================================================================
Skip  1 Package

Nothing to do.
Complete!

DNF issue?

Comment 10 Kevin Kofler 2019-08-29 16:42:38 UTC
> DNF issue?

Yes. It should not process Obsoletes in old versions of the package, exactly because of removed Obsoletes as here. This used to work as expected in Yum and, I think, also in older versions of DNF.

But at least it skips the package and does not enforce the downgrade, so this is better than before the fix, where DNF would not let you install liberation-narrow-fonts at all.

Comment 11 Fedora Update System 2019-08-30 14:20:48 UTC
liberation-fonts-2.00.5-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-09-01 07:04:10 UTC
liberation-fonts-2.00.5-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Ivan Mironov 2019-09-03 17:45:53 UTC
It looks like this is still broken. I see following on two different Fedora 30 systems:

$ sudo dnf upgrade
Last metadata expiration check: 0:09:07 ago on Tue 03 Sep 2019 10:26:54 PM +05.
Dependencies resolved.

 Problem: package liberation-fonts-1:2.00.5-1.fc30.noarch requires liberation-mono-fonts = 1:2.00.5-1.fc30, but none of the providers can be installed
  - cannot install both liberation-mono-fonts-1:2.00.5-1.fc30.noarch and liberation-mono-fonts-1:2.00.5-3.fc30.noarch
  - cannot install the best update candidate for package liberation-narrow-fonts-1.07.6-1.fc30.noarch
  - cannot install the best update candidate for package liberation-mono-fonts-1:2.00.5-3.fc30.noarch
==========================================================================================================================================================================================================
 Package                                                  Architecture                              Version                                               Repository                                 Size
==========================================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 liberation-mono-fonts                                    noarch                                    1:2.00.5-1.fc30                                       fedora                                    494 k
Skipping packages with broken dependencies:
 liberation-fonts                                         noarch                                    1:2.00.5-1.fc30                                       fedora                                    8.0 k

Transaction Summary
==========================================================================================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!

$ rpm -qa | grep liberation
liberation-sans-fonts-2.00.5-3.fc30.noarch
liberation-fonts-common-2.00.5-3.fc30.noarch
liberation-mono-fonts-2.00.5-3.fc30.noarch
liberation-narrow-fonts-1.07.6-1.fc30.noarch
liberation-serif-fonts-2.00.5-3.fc30.noarch

liberation-narrow-fonts in my case is pulled by wine. Problem disappears if I remove liberation-narrow-fonts together with wine. `dnf install wine` after that works as expected without any errors, but then `dnf upgrade` starts failing again.

Comment 14 Jaroslav Mracek 2019-09-05 07:15:53 UTC
*** Bug 1748187 has been marked as a duplicate of this bug. ***

Comment 15 Petr Pisar 2019-09-12 12:42:08 UTC
*** Bug 1751699 has been marked as a duplicate of this bug. ***

Comment 16 customercare 2019-09-12 14:06:57 UTC
Still broken for F29.

Comment 17 Jens Petersen 2019-09-13 05:01:44 UTC
The F29 liberation-narrow-fonts update just went stable about 7 hours ago.


Note You need to log in before you can comment on or make changes to this bug.