Bug 1708597 - Missing openapi CRD definitions for oc explain to work for configs.imageregistry.operator.openshift.io
Summary: Missing openapi CRD definitions for oc explain to work for configs.imageregis...
Keywords:
Status: CLOSED DUPLICATE of bug 1705752
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks: 1708600
TreeView+ depends on / blocked
 
Reported: 2019-05-10 10:15 UTC by Wenjing Zheng
Modified: 2019-05-10 12:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1708600 (view as bug list)
Environment:
Last Closed: 2019-05-10 12:06:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wenjing Zheng 2019-05-10 10:15:07 UTC
Description of problem:
Copied from bug 1705746, should add the description info for these CRDs so that `oc explain` can work when try to explain configs.imageregistry.operator.openshift.io crd:
$ oc explain configs.imageregistry.operator.openshift.io |grep -i description -A 3
DESCRIPTION:
     <empty>


Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-05-09-204138

How reproducible:
Always

Steps to Reproduce:
1.$ oc explain configs.imageregistry.operator.openshift.io |grep -i description -A 3
2.
3.

Actual results:
Get nothing about the description.

Expected results:
Should get the appropriate description for

Additional info:

Comment 1 Paul Weil 2019-05-10 12:06:30 UTC

*** This bug has been marked as a duplicate of bug 1705752 ***


Note You need to log in before you can comment on or make changes to this bug.