Bug 1708600 - Missing openapi CRD definitions for oc explain to work for configs.samples.operator.openshift.io
Summary: Missing openapi CRD definitions for oc explain to work for configs.samples.op...
Keywords:
Status: CLOSED DUPLICATE of bug 1705753
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ImageStreams
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Adam Kaplan
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On: 1705752 1708597 1714775
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-10 10:21 UTC by Wenjing Zheng
Modified: 2019-08-23 20:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1708597
Environment:
Last Closed: 2019-05-10 12:07:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wenjing Zheng 2019-05-10 10:21:07 UTC
+++ This bug was initially created as a clone of Bug #1708597 +++

Description of problem:
Copied from bug 1705746, should add the description info for these CRDs so that `oc explain` can work when try to explain configs.imageregistry.operator.openshift.io crd:
$ oc explain configs.imageregistry.operator.openshift.io |grep -i description -A 3
DESCRIPTION:
     <empty>
$ oc explain configs.samples.operator.openshift.io 
KIND:     Config
VERSION:  imageregistry.operator.openshift.io/v1

DESCRIPTION:
     <empty>


Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-05-09-204138

How reproducible:
Always

Steps to Reproduce:
1.$ oc explain configs.imageregistry.operator.openshift.io
2.$ oc explain configs.samples.operator.openshift.io 
3.

Actual results:
Get nothing about the description.

Expected results:
Should get the appropriate description.

Additional info:

Comment 1 Wenjing Zheng 2019-05-10 10:24:01 UTC
Same to controller-manager
$ oc explain openshiftcontrollermanagers 
KIND:     OpenShiftControllerManager
VERSION:  operator.openshift.io/v1

DESCRIPTION:
     <empty>

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/api-conventions.md#metadata

   spec	<Object> -required-

   status	<Object>

Comment 2 Wenjing Zheng 2019-05-10 10:27:23 UTC
And if use the full name of controllermanager crd. it will return:
$ oc explain openshiftcontrollermanagers.operator.openshift.io
error: field "operator" does not exist

Comment 3 Paul Weil 2019-05-10 12:07:50 UTC

*** This bug has been marked as a duplicate of bug 1705753 ***


Note You need to log in before you can comment on or make changes to this bug.