This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 170904 - logrotate segfaults on what appears to be a valid config file
logrotate segfaults on what appears to be a valid config file
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
:
: 170955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-15 07:51 EDT by Bojan Smojver
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-15 18:57:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Configuration file (505 bytes, text/plain)
2005-10-15 07:51 EDT, Bojan Smojver
no flags Details
strace output (26.17 KB, text/plain)
2005-10-15 07:52 EDT, Bojan Smojver
no flags Details

  None (edit)
Description Bojan Smojver 2005-10-15 07:51:13 EDT
Created attachment 120012 [details]
Configuration file
Comment 1 Bojan Smojver 2005-10-15 07:51:13 EDT
Description of problem:
logrotate segfaults with:

/etc/cron.daily/logrotate:

/etc/cron.daily/logrotate: line 3:  4376 Segmentation fault     
/usr/sbin/logrotate /etc/logrotate.conf

Version-Release number of selected component (if applicable):
3.7.2-6

How reproducible:
Happens every day.

Steps to Reproduce:
1. Do nothing, let cron/anacron run logrotate.

  
Actual results:
logrotate segfaults.

Expected results:
Should work as it used to.

Additional info:
Attaching config file and strace output.

GDB backtrace:
----------------------------
GNU gdb Red Hat Linux (6.3.0.0-1.81rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

(gdb) set args /etc/logrotate.conf
(gdb) r
Starting program: /usr/sbin/logrotate /etc/logrotate.conf
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x8e7000

Program received signal SIGSEGV, Segmentation fault.
0x00b7c026 in free () from /lib/libc.so.6
(gdb) bt
#0  0x00b7c026 in free () from /lib/libc.so.6
#1  0x0804ce6d in main (argc=2, argv=0xbfdac244) at logrotate.c:90
#2  0x00b2d50f in __libc_start_main () from /lib/libc.so.6
#3  0x08049851 in _start ()
----------------------------
Comment 2 Bojan Smojver 2005-10-15 07:52:51 EDT
Created attachment 120013 [details]
strace output
Comment 3 Peter Vrabec 2005-10-15 08:34:18 EDT
check logrotate-3.7.2-7 please,

http://people.redhat.com/pvrabec/rpms/logrotate-3.7.2-7.src.rpm
Comment 4 Bojan Smojver 2005-10-15 18:57:27 EDT
Yeah, appears much better. Thanks.
Comment 5 Peter Vrabec 2005-10-17 02:59:57 EDT
*** Bug 170955 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.