Bug 1709647 - must-gather container logs unavailable
Summary: must-gather container logs unavailable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.z
Assignee: Luis Sanchez
QA Contact: zhou ying
URL:
Whiteboard: 4.1.9
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-14 05:39 UTC by Luis Sanchez
Modified: 2019-08-07 15:06 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-07 15:06:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2010 None None None 2019-08-07 15:06:06 UTC

Description Luis Sanchez 2019-05-14 05:39:40 UTC
Description of problem:

When running `oc adm must-gather` we sometimes get the following message:

    container logs unavailable: container "gather" in pod "must-gather-ndmjw" is waiting to start: PodInitializing

The command runs successfully, but the progress is not displayed (giving the appearance of a hang).

Version-Release number of selected component (if applicable):

4.0.1rc3

Comment 1 Luis Sanchez 2019-05-14 05:42:54 UTC
PR: https://github.com/openshift/origin/pull/22829

Comment 13 Luis Sanchez 2019-08-01 13:33:58 UTC
Same fix as Bug 1705492.
https://github.com/openshift/origin/pull/23036

Comment 15 zhou ying 2019-08-02 05:49:56 UTC
Confirmed with Payload: 4.1.0-0.nightly-2019-08-01-113008, can't reproduce the issue.

Comment 17 errata-xmlrpc 2019-08-07 15:06:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2010


Note You need to log in before you can comment on or make changes to this bug.