Bug 171011 - Include files in wrong directory
Include files in wrong directory
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: synce (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 185465 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 08:21 EDT by Pierre Ossman
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 15:49:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2005-10-17 08:21:36 EDT
The included header files get placed directly in /usr/include when some of them
should be in /usr/include/rra. (There might be more errors but this is the one
causing problems for me.)

The makefile seems correct and the spec does nothing magic to move the files
around. I'm guessing the problem is that the makefile moves the headers by
changing the automake includedir variable (instead of defining a new one). I get
other build errors when trying to rebuild the package on my machine (up to date
rawhide) so I haven't confirmed this.
Comment 1 Andreas Bierfert 2005-10-17 10:08:07 EDT
I fail to see why this is a problem. Putting include files in /usr/include or a
subdir of /usr/include is a mere matter of taste an usefullness and when I took
over the includes had been in /usr/include and I don't see why this should be
changed. 

What Problems do you have? (the current version does not work on rawhide due to
some gcc issues). I am working on this as I finally got a replacement for my old
rawhide box.
Comment 2 Pierre Ossman 2005-10-17 10:26:33 EDT
This would not be a problem if not for the fact that:

a) The included .m4 look for the headers in a rra/ subdir.
b) synce seems to promote using #include <rra/header.h> (as seen from a)).

Putting the files in something other than */rra breaks existing programs
(opensync in my case).
Comment 3 Andreas Bierfert 2005-11-28 15:49:51 EST
As I will put up opensync for review in a short while (just patching
libopensyncs rpath stuff) I will close this. Putting them in %{_includedir}
should be fine...
Comment 4 Andreas Bierfert 2006-03-15 03:53:10 EST
*** Bug 185465 has been marked as a duplicate of this bug. ***
Comment 5 quintesse 2006-07-26 16:36:32 EDT
I have to second Pierre Ossman (#2) that other code around the net, in my case
the opensync synce plugin, seems to expect these includes to be in an rra/ sub
folder.

Don't know who is right and who is wrong though.

Note You need to log in before you can comment on or make changes to this bug.