Bug 185465 - synce-devel puts headers in wrong directory
synce-devel puts headers in wrong directory
Status: CLOSED DUPLICATE of bug 171011
Product: Fedora
Classification: Fedora
Component: synce (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-03-14 17:49 EST by Kristo Kriechbaum
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-15 03:53:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kristo Kriechbaum 2006-03-14 17:49:29 EST
Description of problem:

The synce-devel package installs the headers directly into /usr/include, as
opposed to /usr/include/rra.  This causes problems when trying to install
synce-kde (which provides kde integration with synce) because synce-kde expects
certain header files (syncmgr.h for example) to be in /usr/include/rra.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install synce-devel package
2. download synce-kde-0.9.1.tar.gz from
3. Unzip and run ./configure

Actual results:
Observe error message about syncmgr.h:
  configure: error: Can't find rra/syncmgr.h
Expected results:
rra/syncmgr.h is found.

Additional info:
A developer for synce said that placing all of the synce headers in /usr/include
could cause problems.  For example he said that synce has a timezone.h, but
other things like kde also have a timezone.h.  That is why the synce headers
need to be in /usr/include/rra
Comment 1 Andreas Bierfert 2006-03-15 03:53:05 EST
I have synce-kde in the pipe if you want I can put it up for review... other
then that see #171011

*** This bug has been marked as a duplicate of 171011 ***

Note You need to log in before you can comment on or make changes to this bug.