Bug 171033 - Fedora/Red Hat welcome message colors
Fedora/Red Hat welcome message colors
Status: CLOSED DUPLICATE of bug 147093
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 11:56 EDT by Luke Macken
Modified: 2016-09-19 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-17 16:12:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2005-10-17 11:56:47 EDT
The rc.sysinit script checks if the booting system is Red Hat or Fedora, and
displays a welcome message accordingly.. both with red text for the names.  The
conditional statement is already there to support different colors for both
OS's, so we might as well give Fedora it's own color -- blue.

--- /etc/rc.d/rc.sysinit        2005-10-15 01:25:03.000000000 -0400
+++ rc.sysinit  2005-10-15 01:21:53.000000000 -0400
@@ -95,7 +95,7 @@
  PRODUCT=`sed "s/Red Hat \(.*\) release.*/\1/" /etc/redhat-release`
  echo " $PRODUCT"
 elif LC_ALL=C fgrep -q "Fedora" /etc/redhat-release ; then
- [ "$BOOTUP" = "color" ] && echo -en "\\033[0;31m"
+ [ "$BOOTUP" = "color" ] && echo -en "\\033[0;34m"
  echo -en "Fedora"
  [ "$BOOTUP" = "color" ] && echo -en "\\033[0;39m"
  PRODUCT=`sed "s/Fedora \(.*\) release.*/\1/" /etc/redhat-release`
Comment 1 Bill Nottingham 2005-10-17 16:12:14 EDT

*** This bug has been marked as a duplicate of 147093 ***

Note You need to log in before you can comment on or make changes to this bug.