Bug 1711535 - Enable back TaintBasedEvictions e2e
Summary: Enable back TaintBasedEvictions e2e
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.0
Assignee: Mike Dame
QA Contact: ge liu
URL:
Whiteboard:
: 1711608 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-18 12:54 UTC by Maciej Szulik
Modified: 2019-11-11 19:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-11 19:34:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23523 'None' 'closed' ' Bug 1711535: Convert tbe e2e test to integration test' 2019-11-11 15:10:27 UTC
Github openshift origin pull 23664 'None' 'closed' 'Bug 1711535: Convert tbe e2e to integration test' 2019-11-11 15:10:34 UTC

Description Maciej Szulik 2019-05-18 12:54:23 UTC
In https://github.com/openshift/origin/pull/22833/commits/905039da00a58f946a73412eb0515c89fe73df52 we disabled TaintBasedEvictions test, it should be enabled back.

Comment 7 Maciej Szulik 2019-08-08 12:50:00 UTC
*** Bug 1711608 has been marked as a duplicate of this bug. ***

Comment 8 Maciej Szulik 2019-08-21 12:42:34 UTC
Mike mind picking this one too.

Comment 9 Mike Dame 2019-08-21 17:04:51 UTC
This currently has an upstream PR (needs rebase): https://github.com/kubernetes/kubernetes/pull/80817
and an Origin PR: https://github.com/openshift/origin/pull/23523

I can cherry pick these into new PRs I'll rebase

Comment 10 Mike Dame 2019-08-23 18:15:48 UTC
New upstream PR here: https://github.com/kubernetes/kubernetes/pull/81856

Comment 11 Mike Dame 2019-08-23 18:57:30 UTC
And new origin PR: https://github.com/openshift/origin/pull/23664

Comment 12 Maciej Szulik 2019-08-29 11:05:02 UTC
This most probably won't make 4.2, it requires upstream approval and code freeze is today. Moving to 4.3

Comment 13 Maciej Szulik 2019-11-06 11:53:13 UTC
https://github.com/openshift/origin/pull/23664 merged, moving to modified.

Comment 15 Mike Dame 2019-11-07 21:15:36 UTC
This may need the changes from this upstream PR: https://github.com/kubernetes/kubernetes/pull/84883

and to be removed from this list: https://github.com/openshift/origin/commit/55358f73aa477f401445a47620dea7e81b27bce9

Comment 16 Mike Dame 2019-11-11 19:34:43 UTC
TaintBasedEvictions has been converted to an integration test, and is no longer part of the e2e suite. Because upstream integration tests aren't run against our CI, this bug is no longer valid and can be closed.


Note You need to log in before you can comment on or make changes to this bug.