This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 171188 - wget -c broken
wget -c broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
:
: 171189 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 03:48 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 11:43:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-10-19 03:48:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
wget -c seems broken:

It 
a) Corrupts .listing files.
b) Traverses subdirs multiple times.

Sorry for the imprecise description, cf. below for details ...

Version-Release number of selected component (if applicable):
wget-1.10.2-0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Mirror an arbitrary ftp-directory, e.g.: 
wget --cut-dirs=6 -m -nH \
ftp://ftp.tu-chemnitz.de/pub/linux/fedora-core/4/i386/os/repodata
2. Have a look into the corresponding .listing file,
e.g. repodata/.listing

3. Issue the same command as under 1., but now with "-c" added:
wget --cut-dirs=6 -m -nH -c \
ftp://ftp.tu-chemnitz.de/pub/linux/fedora-core/4/i386/os/repodata


Actual Results:  a) .listing is incorrect (Contains duplicated entries).
b) wget -c bogusly recurses the directory multiple times, instead of one.


Expected Results:  a) Correct .listing
b) Wget traversing directories once.

This had worked with former version of wget.

Additional info:

This issue seems to have appeared with wget-1.10.1-0.fc4.
Former versions did not expose this bug.

Wget-1.10 to me is completely nonfunctional and should be withdrawn/replaced.
Comment 1 Ralf Corsepius 2005-10-19 03:58:39 EDT
*** Bug 171189 has been marked as a duplicate of this bug. ***
Comment 2 Karsten Hopp 2006-09-25 11:43:22 EDT
wget-1.10.2-6 still appends to .listing instead of rewriting it, but resumed
downloads seem to work now.

Note You need to log in before you can comment on or make changes to this bug.