Bug 171189 - wget -c broken
wget -c broken
Status: CLOSED DUPLICATE of bug 171188
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
Depends On:
  Show dependency treegraph
Reported: 2005-10-19 03:54 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-19 03:58:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-10-19 03:54:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
wget -c seems broken:

a) Corrupts .listing files.
b) Traverses subdirs multiple times.

Sorry for the imprecise description, cf. below for details ...

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Mirror an arbitrary ftp-directory, e.g.: 
wget --cut-dirs=6 -m -nH \
2. Have a look into the corresponding .listing file,
e.g. repodata/.listing

3. Issue the same command as under 1., but now with "-c" added:
wget --cut-dirs=6 -m -nH -c \

Actual Results:  a) .listing is incorrect (Contains duplicated entries).
b) wget -c bogusly recurses the directory multiple times, instead of one.

Expected Results:  a) Correct .listing
b) Wget traversing directories once.

This had worked with former version of wget.

Additional info:

This issue seems to have appeared with wget-1.10.1-0.fc4.
Former versions did not expose this bug.

Wget-1.10 to me is completely nonfunctional and should be withdrawn/replaced.
Comment 1 Ralf Corsepius 2005-10-19 03:58:31 EDT
Sorry, I don't know why this PR was submitted twice :(

*** This bug has been marked as a duplicate of 171188 ***

Note You need to log in before you can comment on or make changes to this bug.