Bug 1711948 - chrony helper removes backslashes in chrony.conf
Summary: chrony helper removes backslashes in chrony.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: chrony
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Miroslav Lichvar
QA Contact: Ondrej Mejzlik
URL:
Whiteboard:
Depends On:
Blocks: 1714232
TreeView+ depends on / blocked
 
Reported: 2019-05-20 13:17 UTC by Miroslav Lichvar
Modified: 2019-11-05 22:24 UTC (History)
1 user (show)

Fixed In Version: chrony-3.5-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1714232 (view as bug list)
Environment:
Last Closed: 2019-11-05 22:24:17 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3589 None None None 2019-11-05 22:24:23 UTC

Description Miroslav Lichvar 2019-05-20 13:17:53 UTC
Description of problem:
The /usr/libexec/chrony-helper script is not using the -r option of the read command, which means backslashes in the config file (e.g. in comments) are lost when the file is rewritten with the set-static-source command, and it could possibly lead to other issues (I wasn't able to identify any.)

Version-Release number of selected component (if applicable):
chrony-3.3-3.el8.x86_64

How reproducible:
always

Steps to Reproduce:
1. echo '# test \ test' >> /etc/chrony.conf
2. /usr/libexec/chrony-helper list-static-sources | /usr/libexec/chrony-helper set-static-sources
3. grep test.*comment /etc/chrony.conf

Actual results:
# test comment

Expected results:
# test\ comment

Additional info:

Comment 1 Miroslav Lichvar 2019-05-20 14:29:13 UTC
There are other errors in the script reported by shellcheck. We should fix them where possible.

Comment 5 errata-xmlrpc 2019-11-05 22:24:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3589


Note You need to log in before you can comment on or make changes to this bug.