Bug 1712055 - Confusing Error message: Failed to synchronize cache for repo 'rhel'
Summary: Confusing Error message: Failed to synchronize cache for repo 'rhel'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: yum
Version: 8.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: beta
: 8.0
Assignee: Packaging Maintenance Team
QA Contact: Radek Bíba
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-20 16:50 UTC by Ondrej Hudlicky
Modified: 2020-11-14 13:46 UTC (History)
3 users (show)

Fixed In Version: libdnf-0.35.1-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 22:22:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:3583 None None None 2019-11-05 22:22:15 UTC

Description Ondrej Hudlicky 2019-05-20 16:50:35 UTC
Description of problem:
dnf / yum produces Error: Failed to synchronize cache for repo 'rhel'
even if there is a typo in yum.repos.d file or the url doesn't exist.
This error is most cases misleading. It mentions cache, users will be looking for problems with cache, while most usual cause of this error is typo in config or issue with network connection. 

Version-Release number of selected component (if applicable):
yum-4.0.9.2-5.el8.noarch

How reproducible:
always 

Steps to Reproduce:
1. vim /etc/yum.repos.d/rhel.repo
2. update baseurl to non existing or invalid url
3. yum search foo

Actual results:
Error: Failed to synchronize cache for repo 'rhel'

Expected results:
Experiencing this is one of the most common errors, dnf should probably display information to help user solve the problem (like yum did): 

Error parsing config: Error parsing "baseurl = ...": URL must be http, ftp, file or https not "typo"
OR: Could not resolve host (Check network connections)
OR: HTTP Error 404 - Not Found (Check for typo)

Additional info:
Usability issue with high impact
RHEL7 yum parses the repo file for errors, which dnf seem to be not doing
RHEL8  with debugging shows bit more info # dnf -v search foo
Cannot download repodata/repomd.xml: All mirrors were tried.
But this is still not sufficient to quickly identify root cause of the problem and not diplayed in default debug level.

Comment 1 Daniel Mach 2019-05-31 14:54:31 UTC
I agree that the error message is misleading.
Setting medium priority, because it's impacting UX but it's not extremely important.

I suggest replacing
> Error: Failed to synchronize cache for repo 'rhel'
with
> Error: Failed to download metadata for repo 'rhel'

URL validation is generally a bad idea.
Check bug#1598336 for more details.

Comment 7 errata-xmlrpc 2019-11-05 22:22:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:3583


Note You need to log in before you can comment on or make changes to this bug.