Bug 171206 - flow-tools-devel should have a dependency on zlib-devel
flow-tools-devel should have a dependency on zlib-devel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: flow-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul P Komkoff Jr
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 170511
  Show dependency treegraph
 
Reported: 2005-10-19 10:10 EDT by Paul Howarth
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.68-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-21 13:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2005-10-19 10:10:17 EDT
Description of problem:

/usr/include/ftlib.h includes <zlib.h>, a file from zlib-devel

Without the dependency on zlib-devel, any package requiring flow-tools-devel and
including ftlib.h will not build on a system that does not have zlib-devel
installed. That would include any package being built on the Fedora Extras
buildsystem that did not itself require zlib-devel.

Version-Release number of selected component (if applicable):
0.68-2.fc5

How reproducible:
Easy

Steps to Reproduce:
Try using mock to build perl-Cflow (Bug 170511)
  
Actual results:
Build fails due to missing zlib.h

Expected results:
Build succeeds
Comment 1 Paul P Komkoff Jr 2005-10-19 17:17:36 EDT
I've changed all my local files, but either cvs or my internet appears to be
dead so - sorry for delay, I'm going to sleep now, hope simple "make tag" will
succeed tomorrow.
Comment 2 Paul P Komkoff Jr 2005-10-20 15:14:14 EDT
I've updated it and built, please confirm that everything is working now (as of
Release: 4)
Comment 3 Paul Howarth 2005-10-21 13:07:26 EDT
perl-Cflow now builds successfully in mock without the workaround of adding BR:
zlib-devel in its own spec file, so I'm now happy and will close the bug.

Note You need to log in before you can comment on or make changes to this bug.