This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 171337 - mkfs.cramfs dies creating installer image
mkfs.cramfs dies creating installer image
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
: 171574 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-10-20 17:16 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-07 07:48:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2005-10-20 17:16:52 EDT
Switching to mkfs.cramfs (... removing /usr/bin/mkcramfs broke our scripts, but
I fixed that) causes the creation of the smaller second stage image to fail
  Building minstg.img
  Running mkcramfs  /tmp/instimage.dir.20103   
  /mnt/redhat/devel/katzj/i386/i386/Fedora/base/minstg2.img
  Exceeded MAXENTRIES.  Raise this value in mkcramfs.c and recompile.  Exiting.

The other mkcramfs changed the size of the entry_stack dynamically
Comment 1 Karel Zak 2005-10-20 17:59:03 EDT
The hard coded size is a new odd change by upstream... 

Fixed. Please, update to util-linux >= util-linux-2.13-0.7.pre5.
Comment 2 Jeremy Katz 2005-10-20 18:32:15 EDT
This also seems to break other things in the image -- a number of the files end
up being zero length which shouldn't be.  Backing the package out fixes things...
Comment 3 Karel Zak 2005-10-21 05:46:07 EDT
Please, show my a way how I can reproduce it.

I've tried extract files from stage2 and created image by old version (mkcramfs)
and by new version and there is no difference in the list of files (after mount
by loop).
Comment 4 Jeremy Katz 2005-10-24 09:55:31 EDT
*** Bug 171574 has been marked as a duplicate of this bug. ***
Comment 5 Karel Zak 2005-10-25 17:09:29 EDT
I still cannot reproduce this bug. 

mkfs.cramfs from util-linux-2.13-0.7.pre5:

# wget
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/base/minstg2.img

# mount ./minstg2.img ./mountpoint -o loop

# ./mkfs.cramfs ./mountpoint ./minstg2.img-new

# mount ./minstg2.img-new ./mountpoint-new -o loop

# cd mountpoint    <-- old image
# for f in `find ./ -type f | sort`; do md5sum $f; done > ../old

# cd ../mountpoint-new  <-- new image
# for f in `find ./ -type f | sort`; do md5sum $f; done > ../new

# cd ..

$ md5sum old new
5fadf94c6ee3e861ebe1d1fe3f64d048  old
5fadf94c6ee3e861ebe1d1fe3f64d048  new

It meants that the contents of files in the images is same.
Comment 6 Jeremy Katz 2005-10-26 12:17:52 EDT
Try with stage2.img instead?  I still haven't gotten to looking yet, too many
other things burning :/
Comment 7 Karel Zak 2005-11-04 14:41:39 EST
My previous test has been on FC4 (with FC5 util-linux). Now I do same test with
same src.rpm on FC5 machine and it seems bad... So, I'm able to reproduce this
problem. Sorry...
Comment 8 Karel Zak 2005-11-07 07:48:52 EST
Fixed. Please, update to util-linux-2.13-0.10.pre5.

Note You need to log in before you can comment on or make changes to this bug.