Bug 171340 - mt man page misdescribes fsfm and bsfm arguments
mt man page misdescribes fsfm and bsfm arguments
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mt-st (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
: 171339 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-20 17:34 EDT by Need Real Name
Modified: 2013-07-02 19:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.9b-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 06:24:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-10-20 17:34:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The operation of the fsfm and bsfm arguments is mis-described in the mt man page. 

Version-Release number of selected component (if applicable):
mt-st-0.8-5

How reproducible:
Always

Steps to Reproduce:
1. Read the mt man page.
2.
3.
  

Actual Results:  The man page includes this description:

       bsfm   Backward space count files.  The tape is positioned on the first
              block of the next file.

... and similarly for fsfm.

Expected Results:  The bsfm description should say that "The tape is positioned on the first block of the previous file.", and that fsfm moves to the next file.

Additional info:

Even that description is a bit misleading, in that to re-read a tape file that you've just read requires a "bsfm 2" to return to the beginning of the just-read file.  Perhaps something brief description of how file marks are used in tape positioning would be in order.
Comment 1 Jindrich Novy 2005-10-21 02:35:12 EDT
*** Bug 171339 has been marked as a duplicate of this bug. ***
Comment 2 Jindrich Novy 2005-10-21 02:40:25 EDT
Could you please reformulate the bsfm and fsfm description without any
misleadings to let me fix the man page and send the fix upstream? Thanks.
Comment 3 Need Real Name 2005-10-21 11:10:46 EDT
I'd change the "backward space file mark" command to read:

bsfm
Backward space past count file marks, then forward space one file record.  This
leaves the tape positioned on the first block of the file that is count-1 files
before the current file.

The corresponding change to the "forward space file mark" command should
probably read something like:

fsfm
Forward space past count file marks, then backward space one file record.  This
leaves the tape is positioned on the last block of the file that is count-1
files past the current file.

Just for information, here's how the Solaris man page describes the operation of
the bsf and nbsf commands of the Solaris mt command:

bsf
Back space over count EOF marks.  The  tape  is  positioned on the
beginning-of-tape side of the  EOF mark.

nbsf
Back space count files.  The tape is positioned on the first block of the file.
This is equivalent to count+1 bsf's followed by one  fsf.

I find this description easier to read than the one in the current RH man page.
 Also, there's a difference in how many files are skipped between the bsfm and
nbsf commands.  Under Solaris, an "nbsf 1" moves to the start of the prior file;
under Linux, a "bsfm 2" is required to do the same thing.  The Solaris version
of this command seems more in line with what intuition would lead a user to expect.
Comment 4 Jindrich Novy 2005-10-25 06:24:17 EDT
fsfm and bsfm descriptions are now fixed.
Comment 5 Fedora Update System 2005-10-26 13:21:18 EDT
From User-Agent: XML-RPC

mt-st-0.9b-1.fc4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.