Bug 1714039 - [RFE] In limited resources environments, rebuilding VMs fails due to NUMATopologyFilter because scheduling isn't skipped.
Summary: [RFE] In limited resources environments, rebuilding VMs fails due to NUMATopo...
Keywords:
Status: CLOSED DUPLICATE of bug 1700412
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 17.0 (Wallaby)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: nova-maint
QA Contact: nova-maint
URL:
Whiteboard:
: 1731847 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-26 20:18 UTC by David Hill
Modified: 2019-10-15 15:05 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-15 15:05:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1804502 0 None None None 2019-05-26 20:22:20 UTC
OpenStack gerrit 661503 0 'None' ABANDONED Reschedule instance only if image properties changed. 2021-01-12 05:09:28 UTC
Red Hat Knowledge Base (Solution) 4105801 0 Troubleshoot None Rebuild instance with a different image fails due to NUMATopologyFilter 2019-05-26 20:20:43 UTC

Description David Hill 2019-05-26 20:18:12 UTC
Description of problem:
In limited resources environments, rebuilding VMs fails due to NUMATopologyFilter because scheduling isn't skipped even though the image metadata are the same:

nova-scheduler.log:2019-04-25 15:37:07.031 3002 INFO nova.filters [req-c49164d8-95d4-4483-85ac-7cf6eb5e5264 e5a411de82e94a94ae80181bc710696b 17d1fb77d99b4f24a4898222e8c912ab - - -] Filtering removed all hosts for the request with instance ID 'a89e4dff-f247-4c10-b6fb-4d20faa77af8'. Filter results: ['AvailabilityZoneFilter: (start: 1, end: 1)', 'RamFilter: (start: 1, end: 1)', 'ComputeFilter: (start: 1, end: 1)', 'ComputeCapabilitiesFilter: (start: 1, end: 1)', 'ImagePropertiesFilter: (start: 1, end: 1)', 'ServerGroupAntiAffinityFilter: (start: 1, end: 1)', 'ServerGroupAffinityFilter: (start: 1, end: 1)', 'PciPassthroughFilter: (start: 1, end: 1)', 'NUMATopologyFilter: (start: 1, end: 0)']

Version-Release number of selected component (if applicable):
openstack-nova-compute-14.1.0-40.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create VMs with pinned vcpus until the overcloud is saturated 
2. Try rebuilding one while also changing the image
3.

Actual results:
Fails

Expected results:
Succeeds if metadata is the same.

Additional info:

Comment 1 Artom Lifshitz 2019-05-30 16:52:08 UTC
FWIW, I think the proper long term fix for this is to use Placement update allocations API [1] along with the standard CPU resource tracking spec [2] and eventually NUMA in placement [3] [4]. Not sure what would be an acceptable short-term solution/workaround.

[1] https://developer.openstack.org/api-ref/placement/?expanded=update-allocations-detail#update-allocations
[2] https://review.opendev.org/#/c/555081/
[3] https://review.opendev.org/#/c/662191/
[4] https://review.opendev.org/#/c/658510/

Comment 2 Matthew Booth 2019-05-31 14:45:26 UTC
We think this is a valid bug, but it's still an open question whether we can fix it in OSP10.

Comment 3 Artom Lifshitz 2019-06-07 14:59:07 UTC
We can't fix this in OSP10 unfortunately, but we'd like to keep tracking this for OSP17. It's far away, but realistically it's going to be the first release where we might be able to address this.

Comment 5 Stephen Finucane 2019-07-25 15:31:02 UTC
*** Bug 1731847 has been marked as a duplicate of this bug. ***

Comment 12 smooney 2019-10-15 15:05:29 UTC

*** This bug has been marked as a duplicate of bug 1700412 ***


Note You need to log in before you can comment on or make changes to this bug.