Bug 171528 - segfaults when authenticating to imap server
segfaults when authenticating to imap server
Status: CLOSED DUPLICATE of bug 157521
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
Blocks: 202058
  Show dependency treegraph
Reported: 2005-10-22 07:55 EDT by Kaj J. Niemi
Modified: 2014-03-16 22:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-24 16:23:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2005-10-22 07:55:12 EDT
Description of problem:
Mutt segfaults when attempting to authenticate to an (any) imap server. The
easiest way to test seems to set the spoolfile variable in .muttrc as follows:

set spoolfile=imaps://server:993/INBOX

Version-Release number of selected component (if applicable):
% rpm -qa mutt cyrus-sasl\*

How reproducible:
Seems like always

Steps to Reproduce:
1. start mutt
2. attach with gdb -p to process, continue
3. login
Actual results:

Expected results:
Obviously shouldn't die on me :)

Additional info:
(gdb) conti

Program received signal SIGSEGV, Segmentation fault.
0x0011a259 in _sasl_log () from /usr/lib/libsasl2.so.2
(gdb) bt
#0  0x0011a259 in _sasl_log () from /usr/lib/libsasl2.so.2
#1  0x00faf9c6 in digestmd5_client_plug_init () from
#2  0x00117ea4 in sasl_client_step () from /usr/lib/libsasl2.so.2
#3  0x080c0534 in ?? ()
#4  0x080bfb1c in ?? ()
#5  0x080babe5 in ?? ()
#6  0x080bbd76 in ?? ()
#7  0x080bc3cd in ?? ()
#8  0x08082143 in ?? ()
#9  0x080783cb in ?? ()
#10 0x0076150f in __libc_start_main () from /lib/libc.so.6
#11 0x0804c5a1 in ?? ()
(gdb) quit
Comment 1 Kaj J. Niemi 2005-10-22 08:32:49 EDT
Seems to work if I force imap_authenticators to be just login, plain or both in
.muttrc like this:

set imap_authenticators="login:plain"

While it segfaults before asking for username if imap_authenticators is set to
Comment 2 Bill Nottingham 2005-10-24 16:23:59 EDT
Closing as a duplicate. I can't reproduce this on the imap servers I have access
to. :/

*** This bug has been marked as a duplicate of 157521 ***
Comment 3 Kaj J. Niemi 2005-10-24 17:02:25 EDT
Do those imap servers allow authentication methods besides AUTH=PLAIN or
AUTH=LOGIN? (telnet to port 143, issue the command ". CAPABILITY")
Comment 4 Bill Nottingham 2005-10-24 21:46:44 EDT
No. So that's a starting point.
Comment 5 Fedora Update System 2005-10-27 17:51:57 EDT
From User-Agent: XML-RPC

mutt- has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.