Bug 202058 - segfaults when authenticating to imap server
Summary: segfaults when authenticating to imap server
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mutt   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 171528
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-10 16:03 UTC by Jose Plans
Modified: 2018-10-19 20:36 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0246
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 22:49:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch from fedora fixing the problem in RHEL4 (1.16 KB, patch)
2006-08-10 16:03 UTC, Jose Plans
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0246 normal SHIPPED_LIVE mutt bug fix update 2007-04-28 17:53:46 UTC

Description Jose Plans 2006-08-10 16:03:16 UTC
+++ This bug was initially created as a clone of Bug #171528 +++

Description of problem:
Mutt segfaults when attempting to authenticate to an (any) imap server. The
easiest way to test seems to set the spoolfile variable in .muttrc as follows:

set spoolfile=imaps://server:993/INBOX

Version-Release number of selected component (if applicable):
% rpm -qa mutt cyrus-sasl\*
cyrus-sasl-lib-2.1.21-5.i386
cyrus-sasl-devel-2.1.21-5.i386
mutt-1.4.2.1-3.i386
cyrus-sasl-plain-2.1.21-5.i386
cyrus-sasl-2.1.21-5.i386
cyrus-sasl-md5-2.1.21-5.i386


How reproducible:
Seems like always

Steps to Reproduce:
1. start mutt
2. attach with gdb -p to process, continue
3. login
  
Actual results:
Segfault

Expected results:
Obviously shouldn't die on me :)

Additional info:
(gdb) conti
Continuing.

Program received signal SIGSEGV, Segmentation fault.
0x0011a259 in _sasl_log () from /usr/lib/libsasl2.so.2
(gdb) bt
#0  0x0011a259 in _sasl_log () from /usr/lib/libsasl2.so.2
#1  0x00faf9c6 in digestmd5_client_plug_init () from
/usr/lib/sasl2/libdigestmd5.so.2
#2  0x00117ea4 in sasl_client_step () from /usr/lib/libsasl2.so.2
#3  0x080c0534 in ?? ()
#4  0x080bfb1c in ?? ()
#5  0x080babe5 in ?? ()
#6  0x080bbd76 in ?? ()
#7  0x080bc3cd in ?? ()
#8  0x08082143 in ?? ()
#9  0x080783cb in ?? ()
#10 0x0076150f in __libc_start_main () from /lib/libc.so.6
#11 0x0804c5a1 in ?? ()
(gdb) quit

-- Additional comment from kajtzu@basen.net on 2005-10-22 08:32 EST --
Seems to work if I force imap_authenticators to be just login, plain or both in
.muttrc like this:

set imap_authenticators="login:plain"

While it segfaults before asking for username if imap_authenticators is set to
digest-md5.

-- Additional comment from notting@redhat.com on 2005-10-24 16:23 EST --
Closing as a duplicate. I can't reproduce this on the imap servers I have access
to. :/

*** This bug has been marked as a duplicate of 157521 ***

-- Additional comment from kajtzu@basen.net on 2005-10-24 17:02 EST --
Do those imap servers allow authentication methods besides AUTH=PLAIN or
AUTH=LOGIN? (telnet to port 143, issue the command ". CAPABILITY")

-- Additional comment from notting@redhat.com on 2005-10-24 21:46 EST --
No. So that's a starting point.

-- Additional comment from updates@fedora.redhat.com on 2005-10-27 17:51 EST --
From User-Agent: XML-RPC

mutt-1.4.2.1-4.FC4 has been pushed for FC4, which should resolve this issue.  If
these problems are still present in this version, then please make note of it in
this bug report.

Comment 1 Jose Plans 2006-08-10 16:03:17 UTC
Created attachment 133955 [details]
patch from fedora fixing the problem in RHEL4

Comment 10 Red Hat Bugzilla 2007-05-01 22:49:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0246.html



Note You need to log in before you can comment on or make changes to this bug.