Bug 171571 - dmraid not rebuildable on RHEL4 U2 (device-mapper incompatibility)
dmraid not rebuildable on RHEL4 U2 (device-mapper incompatibility)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dmraid (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-23 09:52 EDT by Jos Vos
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEL4 U3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 07:51:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2005-10-23 09:52:10 EDT
Description of problem:
The dmraid-1.0.0.rc8-1_RHEL4_U2 src.rpm cannot be rebuild on RHEL4 U2 due to an
incompatibility with the device-mapper package in RHEL4 U2 (at least that's what
it looks like).

Version-Release number of selected component (if applicable):
1.0.0.rc8-1_RHEL4_U2

How reproducible:
rpmbuild --rebuild dmraid-1.0.0.rc8-1_RHEL4_U2.src.rpm.

Actual results:
gcc -o dmraid dmraid.o commands.o toollib.o  -static -L../lib \
      -L/var/tmp/dmraid-1.0.0.rc8-1_RHEL4_U2-buildroot/lib -ldmraid -ldevmapper
../lib/libdmraid.a(socket.o)(.text+0x77): In function `daemon_open':
daemon/socket.c:44: warning: Using 'gethostbyname' in statically linked
applications requires at runtime the shared libraries from the glibc version
used for linking
/lib/libdevmapper.a(libdm-common.o)(.text+0x575): In function `set_selinux_context':
/home/xos/gen/updates-test/xlrpm11484/rpm/BUILD/device-mapper.1.01.04/lib/libdm-common.c:207:
undefined reference to `is_selinux_enabled'
/lib/libdevmapper.a(libdm-common.o)(.text+0x591):/home/xos/gen/updates-test/xlrpm11484/rpm/BUILD/device-mapper.1.01.04/lib/libdm-common.c:210:
undefined reference to `matchpathcon'
/lib/libdevmapper.a(libdm-common.o)(.text+0x5e0):/home/xos/gen/updates-test/xlrpm11484/rpm/BUILD/device-mapper.1.01.04/lib/libdm-common.c:218:
undefined reference to `lsetfilecon'
/lib/libdevmapper.a(libdm-common.o)(.text+0x5ef):/home/xos/gen/updates-test/xlrpm11484/rpm/BUILD/device-mapper.1.01.04/lib/libdm-common.c:224:
undefined reference to `freecon'
/lib/libdevmapper.a(libdm-common.o)(.text+0x699):/home/xos/gen/updates-test/xlrpm11484/rpm/BUILD/device-mapper.1.01.04/lib/libdm-common.c:220:
undefined reference to `freecon'
collect2: ld returned 1 exit status
make[1]: *** [dmraid] Error 1
make[1]: Leaving directory `/home/xos/rpm-tmp/BUILD/dmraid/1.0.0.rc8/tools'
make: *** [tools] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.32672 (%build)

Additional info:

When downgrading device-mapper from version 1.01.04-1.0.RHEL4 to
1.01.01-1.RHEL4, it works ok.

The lvm2 package in RHEL4 U2 has a similar problem (see bugzilla #170178).
Comment 1 Milan Broz 2006-04-24 07:51:23 EDT
Fixed in RHEL4 U3 (see comments in bug 170178).

Note You need to log in before you can comment on or make changes to this bug.