Bug 171586 - Anaconda crashes with ImportError: cannot import name RepoMDError
Anaconda crashes with ImportError: cannot import name RepoMDError
Status: CLOSED DUPLICATE of bug 171574
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-23 17:53 EDT by Caerie Houchins
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 09:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caerie Houchins 2005-10-23 17:53:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050927 Fedora/1.0.7-2.1.fc4.nr Firefox/1.0.7

Description of problem:
When booting from the boot.iso and doing an html install with the current stage2.img .buildstamp of :
200510230518.i386
Fedora Core
4.90
Fedora
http://bugzilla.redhat.com/bugzilla/

Anaconda crashes with Traceback (most recent call last):
File "/usr/bin/anaconda", line 1074, in ? 
  from yuminstall import YumBackend
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 36, in ?
  from import config
File "/usr/lib/python2.4/site-packages/yum/config.py", line 34, in ?
  from repos import variableReplace, Repository
File "/usr/lib/python2.4/site-packages/yum.repos.py", line 28, in ?
  from repomd improt repoMDObject
File "/usr/lib/python2.4/site-packages/repomd/repoMDObject.py", line 19, in ?
  from mdErrors import RepoMDerror
ImportError: cannot import name RepoMDError
install exited abnormally

Appears that its not loading the class correctly from mdErrors.pl but I don't know why.

Version-Release number of selected component (if applicable):
daily-build

How reproducible:
Always

Steps to Reproduce:
1. Boot from burnt cdrom with boot.iso
2. choose html install
3. give it the IP and path to my local webserver where stage,img and my rawhide local mirror is located.
  

Actual Results:  Anaconda crashes with Traceback (most recent call last):
File "/usr/bin/anaconda", line 1074, in ? 
  from yuminstall import YumBackend
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 36, in ?
  from import config
File "/usr/lib/python2.4/site-packages/yum/config.py", line 34, in ?
  from repos import variableReplace, Repository
File "/usr/lib/python2.4/site-packages/yum.repos.py", line 28, in ?
  from repomd improt repoMDObject
File "/usr/lib/python2.4/site-packages/repomd/repoMDObject.py", line 19, in ?
  from mdErrors import RepoMDerror
ImportError: cannot import name RepoMDError
install exited abnormally

Expected Results:  a graphical or text based install with anaconda

Additional info:
Comment 1 Jeremy Katz 2005-10-24 09:55:55 EDT

*** This bug has been marked as a duplicate of 171574 ***

Note You need to log in before you can comment on or make changes to this bug.