Bug 1716534 - python-terminaltables fails to build with Python 3.8
Summary: python-terminaltables fails to build with Python 3.8
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-terminaltables
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL: https://copr.fedorainfracloud.org/cop...
Whiteboard:
: 1736542 (view as bug list)
Depends On: 1717662
Blocks: F31FTBFS PYTHON38 1732841
TreeView+ depends on / blocked
 
Reported: 2019-06-03 14:41 UTC by Miro Hrončok
Modified: 2019-08-25 11:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-25 11:31:32 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2019-06-03 14:41:01 UTC
See https://copr.fedorainfracloud.org/coprs/g/python/python3.8/package/python-terminaltables/ for actual logs. This report is automated and not very verbose, but feel free to ping me for help.

Comment 1 Miro Hrončok 2019-07-10 14:19:08 UTC
This is now blocked on pylint. I suggest you don't run pylint in spec.

Comment 2 Charalampos Stratakis 2019-07-30 14:27:37 UTC
Could you drop the pylint dependency?

Comment 3 Terje Røsten 2019-07-31 06:03:19 UTC
A bit unsure what to do here, should %check section be removed?

Comment 4 Miro Hrončok 2019-07-31 10:06:23 UTC
%check
%if %{with_python2}
py.test --cov-report term-missing --cov-report xml --cov terminaltables --cov-config tox.ini tests
%endif
py.test-3 --cov-report term-missing --cov-report xml --cov terminaltables --cov-config tox.ini tests



The check section does currently three things:


 1. runs the actual testes - good, we want that
 2. runs coverity report - bah, we don't really care
 3. runs pylint - boom, breaks things

Ideally, drop the coverage and lint stuff only. Like this:

-BuildRequires: python3-pylint
-BuildRequires: python3-flake8
-BuildRequires: python3-pep8
-BuildRequires: python3-pytest-cov
+BuildRequires: python3-pytest


-py.test-3 --cov-report term-missing --cov-report xml --cov terminaltables --cov-config tox.ini tests
+py.test-3 tests



(I actually get some test failure on rawhide when I try to do this.)

Comment 5 Ben Cotton 2019-08-13 16:55:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 6 Ben Cotton 2019-08-13 18:51:52 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 7 Miro Hrončok 2019-08-14 22:24:21 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 8 Terje Røsten 2019-08-18 12:20:53 UTC
*** Bug 1736542 has been marked as a duplicate of this bug. ***

Comment 9 Miro Hrončok 2019-08-21 16:35:02 UTC
The f32-python side tag has been merged. In order to rebuild the package, do it in regular rawhide, but please wait until python3-3.8 is tagged:

  $ koji wait-repo f32-build --build python3-3.8.0~b3-3.fc32


If your built already started in f32-python, after it is finished, please tag it to rawhide with:

  $ koji tag-build f32-pending <nvr>

For example:

  $ koji tag-build f32-pending libreoffice-6.3.0.4-3.fc32

Thanks!

(This comment is mass posted to all bugzillas blocking the PYTHON38 tracking bug.)

Comment 10 Miro Hrončok 2019-08-21 17:29:08 UTC
(Python 3.8 has landed in the rawhide buildroot.)

Comment 11 Terje Røsten 2019-08-25 11:31:32 UTC
Thanks for report and fix. Pushed:
 https://koji.fedoraproject.org/koji/buildinfo?buildID=1363985


Note You need to log in before you can comment on or make changes to this bug.