Bug 171693 - provide support for embolden API
provide support for embolden API
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgnomeprint22 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: i18n
: 205559 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-25 08:15 EDT by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 06:19:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-10-25 08:15:47 EDT
Description of problem:
Was trying embolden font feature and noticed that when I tried to print the
document with mix of normal and bold fonts, the printout is all normal and all
the bold are gone.

Version-Release number of selected component (if applicable):
libgnomeprint22-2.12.1-2
freetype-2.1.10-1
cairo-1.0.2-2
fontconfig-2.3.2-1

How reproducible:
Always

Steps to Reproduce:
1.start evolution and compose mail with HTML mode
2.copy and paste the supplied text "ja_JP:あか" 
3.bold the font and print
  
Actual results:
no bold

Expected results:
bold

Additional info:
Comment 1 A S Alam 2006-08-30 06:30:17 EDT
yet not working. Only Normal text printed out. 
Tested with following version:
-----------
libgnomeprint22-2.12.1-8
freetype-2.2.1-7.fc6
cairo-1.2.4-1.fc6
fontconfig-2.3.95-11.fc6
-----------
Comment 2 Akira TAGOH 2006-09-07 07:00:19 EDT
*** Bug 205559 has been marked as a duplicate of this bug. ***
Comment 3 Akira TAGOH 2006-09-21 06:19:35 EDT
I was looking into this bug, and it looks like not feasible at this timeframe,
because libgnomeprint parses TrueType fonts with their own library to embed the
outline into PostScript. so if we are trying to support the synthetic
emboldening in libgnomeprint, need to implement similar things in their own
TrueType font library.

Note You need to log in before you can comment on or make changes to this bug.