Bug 1717028 - Networking details are missing for some deployment configs in web console overview
Summary: Networking details are missing for some deployment configs in web console ove...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.11.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1717533 1717535
TreeView+ depends on / blocked
 
Reported: 2019-06-04 14:52 UTC by Abhishek
Modified: 2019-06-26 09:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, a service would not correctly show up in the project overview when it selected the `deploymentconfig` label that is automatically set for pods created by a deployment config. We now correctly show services that select the `deploymentconfig` label on the overview.
Clone Of:
: 1717533 (view as bug list)
Environment:
Last Closed: 2019-06-26 09:08:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
NetworkingDetails (189.72 KB, image/png)
2019-06-14 09:38 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1605 None None None 2019-06-26 09:08:20 UTC

Description Abhishek 2019-06-04 14:52:05 UTC
Description of problem: The pod info details are missing in the web UI


Version-Release number of selected component (if applicable):
OCP 3.7

Verified the below  output and it's available:
# oc get ep,svc,route

Comment 1 Samuel Padgett 2019-06-04 14:53:12 UTC
Hi, there's no detail in this bug. Can you describe what the issue is? Is this a problem in 3.7 or 3.11?

Comment 8 Samuel Padgett 2019-06-05 15:37:55 UTC
The issue is that console is comparing the service `spec.selector` to the labels in the deployment config `spec.template.metadata.labels`. In this case, the service is selecting on a value that is added to the pod automatically by the deployment controller, so it's not matching what's in the pod template in the deployment config itself. We might need to special case this specific scenario.

Comment 9 Samuel Padgett 2019-06-05 16:01:25 UTC
The workaround is to add `deploymentconfig: <name>` to `spec.template.metadata.labels` in the deployment config. Then the networking information will appear in the overview.

Moving the Bugzilla to medium severity since it's an uncommon use case and there's a workaround. (We will still look at addressing this.)

Comment 12 Yadan Pei 2019-06-14 09:38:26 UTC
1. Create project and resources
$ oc new-project gdsp-test
$ oc create -f ui/dc_pingtokengenerator
deploymentconfig.apps.openshift.io/pingtokengenerator created
$ oc create -f Case_02396062_05June2019/svc_pingtokengenerator
service/pingtokengenerator created
$ oc create -f Case_02396062_05June2019/route_pingtokengenerator
route.route.openshift.io/pingtokengenerator created

2. Go to project Overview, click on Deployment Configs to show its details, Networking details are shown on page

Verified on OpenShift Web Console: v3.11.117

Comment 13 Yadan Pei 2019-06-14 09:38:51 UTC
Created attachment 1580631 [details]
NetworkingDetails

Comment 15 errata-xmlrpc 2019-06-26 09:08:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1605


Note You need to log in before you can comment on or make changes to this bug.