Bug 171711 - Non-gcj builds are not noarch
Non-gcj builds are not noarch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-25 10:36 EDT by Ian Pilcher
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-27 16:29:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2005-10-25 10:36:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Non-gcj Eclipse builds are not noarch, because of libswt-gtk2.

Version-Release number of selected component (if applicable):
eclipse-3.1.1-1jpp_1fc.FC4.1

How reproducible:
Always

Steps to Reproduce:
1.  Download and install the eclipse SRPM.
2.  Edit the SPEC file, setting gcj-support to 0.
3.  Attempt to build the package.
  

Actual Results:  Didn't actually try it.  Build will probably fail.  If it succeeds, package will
be incorrectly tagged as noarch.

Expected Results:  Architecture-specific package should be built.

Additional info:

The Eclipse source appears to support x86, x86_64, ppc, ppc64, and ia64.
Comment 1 Andrew Overholt 2005-10-25 14:43:38 EDT
I've fixed this in CVS.  I guess we can close the next time I do a build (which
*will* happen for FC4-updates due to bug 168040).
Comment 2 Andrew Overholt 2005-10-27 16:29:02 EDT
My build just finished and I'll get it out as a potential FC4 update.  Let's
close this.  Re-open if you're not happy.

Note You need to log in before you can comment on or make changes to this bug.