Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1717439 - Marketplace operator does not properly define related resources
Summary: Marketplace operator does not properly define related resources
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.2.0
Assignee: Aravindh Puthiyaparambil
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks: 1717509
TreeView+ depends on / blocked
 
Reported: 2019-06-05 13:21 UTC by Eric Rich
Modified: 2019-10-16 06:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The must-gather tool requires a field, RelatedObjects, in the ClusterOperator CR to be populated with ObjectReferences of the resources associated with the operator. This is missing for marketplace. Consequence: The must-gather tool is not able to gather enough information about the marketplace operator. Fix: Oopulates this field with the operator's namespace and the OperatorSource/CatalogSourceConfig/CatalogSource resources. Result: The must-gather tool is able to gather enough information about the marketplace operator.
Clone Of:
: 1717509 (view as bug list)
Environment:
Last Closed: 2019-10-16 06:31:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:31:26 UTC

Description Eric Rich 2019-06-05 13:21:35 UTC
Description of problem: 

The marketplace operator does not properly define related resources. This means support collection tools (like must-gather) can't collect the necessary information needed to debug issues with this operator. 

Version-Release number of selected component (if applicable): 4.1.0 (GA)

How reproducible: 100% of the time. 


Steps to Reproduce:
1. Run must-gather collection tools.

Actual results: This is missing information needed to debug the marketplace operator. 

Expected results: must-gather should collect the necessary resources, however, the way this works (it uses related resources), to collect this information. 

https://github.com/openshift/must-gather/blob/master/pkg/cmd/inspect/resource.go#L148-L164


Additional info:

Comment 1 Aravindh Puthiyaparambil 2019-06-07 20:13:24 UTC
https://github.com/operator-framework/operator-marketplace/pull/205

Comment 11 errata-xmlrpc 2019-10-16 06:31:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.