Bug 1717509 - Marketplace operator does not properly define related resources
Summary: Marketplace operator does not properly define related resources
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.1.z
Assignee: aravindh
QA Contact: Fan Jia
URL:
Whiteboard: 4.1.8
: 1717732 (view as bug list)
Depends On: 1717439
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-05 16:05 UTC by aravindh
Modified: 2019-07-31 02:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The must-gather tool requires a field, RelatedObjects, in the ClusterOperator CR to be populated with ObjectReferences of the resources associated with the operator. This is missing for marketplace. Consequence: The must-gather tool is not able to gather enough information about the marketplace operator. Fix: Oopulates this field with the operator's namespace and the OperatorSource/CatalogSourceConfig/CatalogSource resources. Result: The must-gather tool is able to gather enough information about the marketplace operator.
Clone Of: 1717439
Environment:
Last Closed: 2019-07-31 02:44:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1866 None None None 2019-07-31 02:45:02 UTC

Description aravindh 2019-06-05 16:05:00 UTC
+++ This bug was initially created as a clone of Bug #1717439 +++

Description of problem: 

The marketplace operator does not properly define related resources. This means support collection tools (like must-gather) can't collect the necessary information needed to debug issues with this operator. 

Version-Release number of selected component (if applicable): 4.1.0 (GA)

How reproducible: 100% of the time. 


Steps to Reproduce:
1. Run must-gather collection tools.

Actual results: This is missing information needed to debug the marketplace operator. 

Expected results: must-gather should collect the necessary resources, however, the way this works (it uses related resources), to collect this information. 

https://github.com/openshift/must-gather/blob/master/pkg/cmd/inspect/resource.go#L148-L164


Additional info:

Comment 1 aravindh 2019-07-17 23:56:32 UTC
*** Bug 1717732 has been marked as a duplicate of this bug. ***

Comment 2 Wei Sun 2019-07-24 07:06:49 UTC
The fix is merged to 4.1.0-0.nightly-2019-07-24-051320 ,please check if we could verify it.

Comment 6 errata-xmlrpc 2019-07-31 02:44:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1866


Note You need to log in before you can comment on or make changes to this bug.