Bug 1717794 - OLM operator does not properly define related resources
Summary: OLM operator does not properly define related resources
Keywords:
Status: CLOSED DUPLICATE of bug 1745272
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.z
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-06 08:29 UTC by Jian Zhang
Modified: 2019-08-28 01:58 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-27 22:50:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 979 0 None None None 2019-08-07 13:31:22 UTC

Description Jian Zhang 2019-06-06 08:29:19 UTC
Description of problem:
This bug is similar to bug 1717439, the OLM operator does not properly define related resources too. This means support collection tools (like must-gather) can't collect the necessary information needed to debug issues with this operator. 

Version-Release number of selected component (if applicable):
Source commit id: 586ffaf57b5da9cc2301b01e2ea10ce6117928c9
mac:~ jianzhang$ oc rsh catalog-operator-586d9f556f-bkr6t 
sh-4.2$ olm --version
OLM version: 0.9.0
git commit: a448318

How reproducible:
always

Steps to Reproduce:
1. Install OCP 4.1.
2. Run `oc adm must-gather` command.
mac:~ jianzhang$ oc adm must-gather 
namespace/openshift-must-gather-f8dnx created
clusterrolebinding.rbac.authorization.k8s.io/must-gather-86n4q created
container logs unavailable: container "gather" in pod "must-gather-c4sps" is waiting to start: PodInitializingreceiving file list ... done
created directory must-gather.local.4479072156740355691
./
audit_logs/
...


3. Check the OLM operator logs.

Actual results:
No OLM info:
mac:~ jianzhang$ ls must-gather.local.4479072156740355691/namespaces/ |grep lifecycle
mac:~ jianzhang$ 


Expected results:
OLM should provide the related resources so that the `oc` gather logs info.

Additional info:

Comment 2 Stephen Cuppett 2019-08-27 11:27:05 UTC
This was a cherry-pick to 4.1 of BZ1727032 (the 4.2 bug).

Comment 4 Jeff Peeler 2019-08-27 22:48:27 UTC
The title of this bug indicates it's a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1745272. The link is a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1743748. I think this bug can be closed.

Comment 5 Jeff Peeler 2019-08-27 22:50:40 UTC

*** This bug has been marked as a duplicate of bug 1745272 ***

Comment 7 Jeff Peeler 2019-08-28 01:58:25 UTC
I didn't really look at which bug was older, just that there was duplication. Also, this bug was improperly linked to another bug, so why not close the one with the noise?


Note You need to log in before you can comment on or make changes to this bug.