Bug 1718027 - [4.1.z] Kube-scheduler-operator entering a permanent degraded state
Summary: [4.1.z] Kube-scheduler-operator entering a permanent degraded state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.z
Assignee: ravig
QA Contact: Weinan Liu
URL:
Whiteboard: 4.1.2
Depends On: 1717618
Blocks: 1721566
TreeView+ depends on / blocked
 
Reported: 2019-06-06 17:29 UTC by Seth Jennings
Modified: 2019-06-19 06:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1717618
: 1721566 (view as bug list)
Environment:
Last Closed: 2019-06-19 06:45:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1382 0 None None None 2019-06-19 06:45:44 UTC

Description Seth Jennings 2019-06-06 17:29:00 UTC
+++ This bug was initially created as a clone of Bug #1717618 +++

Description of problem:

Kube-scheduler-operator entering into a state of permanent degraded state, where it is not recovering from.

Version-Release number of selected component (if applicable):
4.2.x

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from ravig on 2019-06-05 19:56:04 UTC ---

https://github.com/openshift/cluster-kube-scheduler-operator/pull/140

Comment 5 Sunil Choudhary 2019-06-14 03:41:28 UTC
Monitored on 3 clusters for around 24 hours and kube-scheduler operator is not degraded.

$ oc version --short
Client Version: v4.1.0-201905191700+7bd2e5b-dirty
Server Version: v1.13.4+d4417a7

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-06-12-205455   True        False         21h     Cluster version is 4.1.0-0.nightly-2019-06-12-205455

$ oc get clusteroperator kube-scheduler
NAME             VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
kube-scheduler   4.1.0-0.nightly-2019-06-12-205455   True        False         False      24h


$ oc version --short
Client Version: v4.1.0-201905191700+7bd2e5b-dirty
Server Version: v1.13.4+d4417a7

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-06-12-205455   True        False         25h     Cluster version is 4.1.0-0.nightly-2019-06-12-205455

$ oc get clusteroperator kube-scheduler
NAME             VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
kube-scheduler   4.1.0-0.nightly-2019-06-12-205455   True        False         False      25h

Comment 7 errata-xmlrpc 2019-06-19 06:45:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1382


Note You need to log in before you can comment on or make changes to this bug.