Bug 1721566 - [4.1.z] Kube-scheduler-operator entering a permanent degraded state
Summary: [4.1.z] Kube-scheduler-operator entering a permanent degraded state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.z
Assignee: ravig
QA Contact: scheng
URL:
Whiteboard:
: 1722835 (view as bug list)
Depends On: 1717618 1718027
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-18 14:50 UTC by ravig
Modified: 2019-06-26 08:50 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1718027
Environment:
Last Closed: 2019-06-26 08:50:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1589 None None None 2019-06-26 08:50:26 UTC

Comment 1 ravig 2019-06-18 14:53:13 UTC
Last release missed following patches. So, I am adding them now.

https://github.com/openshift/cluster-kube-scheduler-operator/pull/143

https://github.com/openshift/cluster-kube-scheduler-operator/pull/146

Comment 2 ravig 2019-06-18 14:55:22 UTC
Without the above patches, we may still end up in a degraded state from which we cannot recover

Comment 3 ravig 2019-06-19 01:44:39 UTC
Both the following PRs merged:

https://github.com/openshift/cluster-kube-scheduler-operator/pull/147

Comment 7 David Eads 2019-06-24 17:28:04 UTC
*** Bug 1722835 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2019-06-26 08:50:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1589


Note You need to log in before you can comment on or make changes to this bug.