Bug 1718163 - Docs about Exposing the Openshift internal registry are not correct for 4.1.0
Summary: Docs about Exposing the Openshift internal registry are not correct for 4.1.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.z
Assignee: Brandi
QA Contact: Wenjing Zheng
Vikram Goyal
URL:
Whiteboard:
: 1717297 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-07 06:53 UTC by Praveen Kumar
Modified: 2019-08-02 19:32 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-02 19:32:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1589 None None None 2019-06-26 08:51:05 UTC

Description Praveen Kumar 2019-06-07 06:53:39 UTC
Document URL: https://docs.openshift.com/container-platform/4.1/registry/securing-exposing-registry.html

Section Number and Name: Document for exposing registry for secure and un-secure way is not up to date.

Additional information: https://github.com/openshift/openshift-docs/issues/15113

Comment 2 Brandi 2019-06-07 16:40:07 UTC
Pulling comment from Github issue: https://github.com/openshift/openshift-docs/issues/15113#event-2396784723

Which section(s) is the issue in?

Exposing a non-secure registry manually
What needs fixing?

As of now when you follow this section you are not able to expose the unsecured registry also the registry service is part of openshift-image-registry namespace but in the document it shows default namespace. Does this document tested or still in the progress ?

Comment 3 Brandi 2019-06-12 18:18:00 UTC
Adam and I met to start overhauling this content. Draft PR open: https://github.com/openshift/openshift-docs/pull/15370

Comment 4 Sudha Ponnaganti 2019-06-19 03:25:54 UTC
Need validation so putting in 4.1.3 but can be validated anytime

Comment 7 errata-xmlrpc 2019-06-26 08:50:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1589

Comment 9 Vikram Goyal 2019-07-01 05:35:03 UTC
*** Bug 1717297 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.