Bug 1718302 - libunity fails to build with Python 3.8
Summary: libunity fails to build with Python 3.8
Keywords:
Status: CLOSED DUPLICATE of bug 1736053
Alias: None
Product: Fedora
Classification: Fedora
Component: libunity
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1718278
Blocks: F32FTBFS F32FailsToInstall PYTHON38
TreeView+ depends on / blocked
 
Reported: 2019-06-07 12:54 UTC by Petr Viktorin
Modified: 2019-09-16 15:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-16 15:24:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Viktorin 2019-06-07 12:54:25 UTC
libunity fails to build with Python 3.8.0b1.

This looks like an error in Vala code; I don't know what it means. Can I ask for help debugging this?
BUILDSTDERR: dee-1.0.vapi:44.35-44.44: error: construct properties not supported for specified property type
BUILDSTDERR: 		public Dee.Filter filter { get; construct; }
BUILDSTDERR: 		                                ^^^^^^^^^^

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.8/fedora-rawhide-x86_64/00925626-libunity/

For all our attempts to build libunity with Python 3.8, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.8/package/libunity/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.8:
https://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Let us know here if you have any questions.

Comment 1 Miro Hrončok 2019-07-10 15:01:02 UTC
This seems related to bz1718278.

Comment 2 Petr Viktorin 2019-07-30 14:45:47 UTC
There's now another issue:

error: Creation method of abstract class cannot be public.
   public DeprecatedScopeBase (string dbus_path_, string id_)
   ^^^^^^^^^^^^^^^^^^^^^^^^^^
 unity-aggregator-scope.vala:54.3-54.24: error: Creation method of abstract class cannot be public.
   public AggregatorScope (string dbus_path_, string id_, MergeMode merge_mode = AggregatorScope.MergeMode.OWNER_SCOPE, bool proxy_filter_hints = false)
   ^^^^^^^^^^^^^^^^^^^^^^
 make[2]: *** [Makefile:1389: libunity_la_vala.stamp] Error 1
 make[1]: *** [Makefile:571: all-recursive] Error 1
 make: *** [Makefile:475: all] Error 2
 error: Bad exit status from /var/tmp/rpm-tmp.4qvqcx (%build)


Full log: https://copr-be.cloud.fedoraproject.org/results/@python/python3.8/fedora-rawhide-x86_64/00978795-libunity/build.log.gz

Comment 3 Ben Cotton 2019-08-13 16:47:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 4 Miro Hrončok 2019-08-14 22:24:41 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 5 Miro Hrončok 2019-08-21 16:35:24 UTC
The f32-python side tag has been merged. In order to rebuild the package, do it in regular rawhide, but please wait until python3-3.8 is tagged:

  $ koji wait-repo f32-build --build python3-3.8.0~b3-3.fc32


If your built already started in f32-python, after it is finished, please tag it to rawhide with:

  $ koji tag-build f32-pending <nvr>

For example:

  $ koji tag-build f32-pending libreoffice-6.3.0.4-3.fc32

Thanks!

(This comment is mass posted to all bugzillas blocking the PYTHON38 tracking bug.)

Comment 6 Miro Hrončok 2019-08-21 17:29:26 UTC
(Python 3.8 has landed in the rawhide buildroot.)

Comment 7 Miro Hrončok 2019-09-16 08:38:37 UTC
This issue is blocking the Python 3.8 rebuilds. If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32.
Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Could you please look into this?

Comment 8 Rex Dieter 2019-09-16 15:18:09 UTC
Resubmitting build, last attempt failed to due buildroot broken dependencies.

Comment 9 Rex Dieter 2019-09-16 15:23:01 UTC
Build failure isn't python-related (vala), see also bug #1736053

Comment 10 Miro Hrončok 2019-09-16 15:24:42 UTC
Marking as duplicite then.

*** This bug has been marked as a duplicate of bug 1736053 ***


Note You need to log in before you can comment on or make changes to this bug.