Bug 1736053 - libunity: vala-related FTBFS in Fedora rawhide/f31
Summary: libunity: vala-related FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libunity
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1718302 (view as bug list)
Depends On:
Blocks: F31FTBFS F32FTBFS F32FailsToInstall PYTHON38 1732841
TreeView+ depends on / blocked
 
Reported: 2019-08-01 14:33 UTC by Fedora Release Engineering
Modified: 2019-11-12 20:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-12 20:01:34 UTC
Type: ---


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2019-08-01 14:33 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-08-01 14:33 UTC, Fedora Release Engineering
no flags Details
state.log (665 bytes, text/plain)
2019-08-01 14:33 UTC, Fedora Release Engineering
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1844158 None None None 2019-09-16 15:32:25 UTC

Description Fedora Release Engineering 2019-08-01 14:33:27 UTC
libunity failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36635189


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix libunity at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
libunity will be orphaned. Before branching of Fedora 32,
libunity will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-08-01 14:33:30 UTC
Created attachment 1597558 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2019-08-01 14:33:33 UTC
Created attachment 1597559 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-08-01 14:33:35 UTC
Created attachment 1597560 [details]
state.log

Comment 4 Ben Cotton 2019-08-13 18:26:50 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 5 Rex Dieter 2019-09-16 15:22:21 UTC
Failure appears to be vala-related:

make[2]: Entering directory '/builddir/build/BUILD/libunity-7.1.4/src'
/usr/bin/valac -C -H unity.h -d . --gir=Unity-7.0.gir --library unity --internal-vapi=unity-internal.vapi --internal-header=unity-internal.h --target-glib=2.32 --thread --use-header --vapidir ../vapi --vapidir ../protocol --vapidir . --pkg unity-protocol --pkg config --pkg unity-trace --pkg glib-2.0 --pkg gmodule-2.0 --pkg gobject-2.0 --pkg gio-2.0 --pkg gio-unix-2.0 --pkg dee-1.0 --pkg Dbusmenu-0.4  unity-appinfo-manager.vala unity-icon.vala unity-inspector.vala unity-io.vala unity-launcher.vala unity-category.vala unity-filters.vala unity-preferences-manager.vala unity-merge-strategy.vala unity-models.vala unity-search.vala unity-synchronizer.vala unity-previews.vala unity-result-activation.vala unity-scope-interface.vala unity-scope-dbus-connector.vala unity-scope-dbus-impl.vala unity-scope-channel.vala unity-deprecated-scope.vala unity-deprecated-scope-impl.vala unity-aggregator-scope.vala unity-aggregator-scope-private.vala unity-master-scope.vala unity-simple-scope.vala unity-scope-loader.vala unity-scope-tracker.vala unity-sound-menu.vala unity-sound-menu-mpris.vala unity-utils.vala
Command-line option `--thread` is deprecated and will be ignored
Compilation failed: 2 error(s), 0 warning(s)
BUILDSTDERR: unity-deprecated-scope.vala:64.3-64.28: error: Creation method of abstract class cannot be public.
BUILDSTDERR:   public DeprecatedScopeBase (string dbus_path_, string id_)
BUILDSTDERR:   ^^^^^^^^^^^^^^^^^^^^^^^^^^
BUILDSTDERR: unity-aggregator-scope.vala:54.3-54.24: error: Creation method of abstract class cannot be public.
BUILDSTDERR:   public AggregatorScope (string dbus_path_, string id_, MergeMode merge_mode = AggregatorScope.MergeMode.OWNER_SCOPE, bool proxy_filter_hints = false)
BUILDSTDERR:   ^^^^^^^^^^^^^^^^^^^^^^
BUILDSTDERR: make[2]: *** [Makefile:1389: libunity_la_vala.stamp] Error 1
make[2]: Leaving directory '/builddir/build/BUILD/libunity-7.1.4/src'
BUILDSTDERR: make[1]: *** [Makefile:571: all-recursive] Error 1

Comment 6 Miro Hrončok 2019-09-16 15:24:42 UTC
*** Bug 1718302 has been marked as a duplicate of this bug. ***

Comment 7 Rex Dieter 2019-09-16 15:32:25 UTC
Reported upstream,

https://bugs.launchpad.net/ubuntu/+source/libunity/+bug/1844158

Comment 8 Fedora Release Engineering 2019-09-22 04:30:14 UTC
Dear Maintainer,

your package has not been built successfully in 31. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 32 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 31 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/32/Schedule

Comment 9 Fedora Release Engineering 2019-09-29 04:27:29 UTC
Dear Maintainer,

your package has not been built successfully in 31. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 32 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 31 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/32/Schedule

Comment 10 Fedora Release Engineering 2019-10-06 04:24:56 UTC
Dear Maintainer,

your package has not been built successfully in 31. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 32 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 31 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/32/Schedule

Comment 11 Fedora Release Engineering 2019-10-13 04:24:50 UTC
Dear Maintainer,

your package has not been built successfully in 31. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 32 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 31 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/32/Schedule

Comment 12 Fedora Release Engineering 2019-10-20 04:24:47 UTC
Dear Maintainer,

your package has not been built successfully in 31. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 32 according to the schedule [3],
any packages not successfully rebuilt at least on 30 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/32/Schedule

Comment 13 Fedora Release Engineering 2019-10-27 04:24:44 UTC
Dear Maintainer,

your package has not been built successfully in 31. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 32 according to the schedule [3],
any packages not successfully rebuilt at least on 30 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/32/Schedule

Comment 14 Fedora Release Engineering 2019-11-03 04:24:08 UTC
Dear Maintainer,

your package has not been built successfully in 31. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 32 according to the schedule [3],
any packages not successfully rebuilt at least on 30 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/32/Schedule

Comment 15 Rex Dieter 2019-11-09 17:09:54 UTC
Upstream claims to have a patch to fix this, will try to take a look asap.


Note You need to log in before you can comment on or make changes to this bug.