Bug 171836 - non-english characters in file names in recent documents menu are displayed as squares
non-english characters in file names in recent documents menu are displayed a...
Status: CLOSED DUPLICATE of bug 180124
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2005-10-26 17:17 EDT by Pavel Rosenboim
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.1-143.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-09 08:14:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
file with name in russian (5.79 KB, application/vnd.oasis.opendocument.text)
2005-10-27 04:56 EDT, Pavel Rosenboim
no flags Details
working for me (45.17 KB, image/png)
2005-10-27 05:11 EDT, Caolan McNamara
no flags Details
fc4 update of 2.0.1-143.2.1 (42.50 KB, image/png)
2005-12-05 06:15 EST, Caolan McNamara
no flags Details
fc-match (7.86 KB, application/octet-stream)
2005-12-05 06:16 EST, Caolan McNamara
no flags Details
output of fc-match --verbose --sort "Sans" (19.40 KB, text/plain)
2005-12-05 13:41 EST, Pavel Rosenboim
no flags Details
bzipped font file (380.90 KB, application/octet-stream)
2005-12-06 03:28 EST, Pavel Rosenboim
no flags Details

  None (edit)
Description Pavel Rosenboim 2005-10-26 17:17:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
After closing file whose name contains non-english characters, the entry in File /"Recent Documents" menu is displayed as squares.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create new file
2. Save it, giving it name with non-english characters (I tryed cyrillic and hebrew characters), then close the file
3. Open File/"Recent Documents" menu

Actual Results:  Non-english characters in the file name displayed as squares.

Expected Results:  File name should be displayed correctly.

Additional info:

This did work in previous version (1.9.125)
Comment 1 Caolan McNamara 2005-10-27 04:39:42 EDT
Can you attach a tiny sample document with a known "bad" name ?
Comment 2 Pavel Rosenboim 2005-10-27 04:56:49 EDT
Created attachment 120453 [details]
file with name in russian

What really matters is a file name and not a content
Comment 3 Caolan McNamara 2005-10-27 05:11:06 EDT
Created attachment 120455 [details]
working for me

looking ok for me. So...

1) KDE or GNOME ?
2) what's the output of locale ?

This might be a font/glyph substitution thing which depends on what font is
being user for the UI
Comment 4 Pavel Rosenboim 2005-10-27 05:19:46 EDT

[pavel@pashar ~]$ locale

The change in behaviour happened after latest openoffice update.
Comment 5 Caolan McNamara 2005-10-27 05:30:19 EDT
very odd, after you open the document does 

a) the title bar have the filename displayed correctly and 
b) does file->Properties->general have the filename displayed correctly ?
Comment 6 Pavel Rosenboim 2005-10-27 05:37:18 EDT
The title bar is correct, but properties are not.
Comment 7 Caolan McNamara 2005-10-27 05:49:21 EDT
I wonder if unselecting tools->options->openoffice.org->view->use system font
for user interface makes any difference
Comment 8 Pavel Rosenboim 2005-10-27 05:55:34 EDT
It makes. Everything is displayed correctly now, and it also makes things a bit
Comment 9 Caolan McNamara 2005-10-27 06:02:08 EDT
I wonder if you know what your "normal" gnome system font is ?
Comment 10 Pavel Rosenboim 2005-10-27 06:05:29 EDT
Application and Desktop fonts: Sans/10
Window title: Sans Bold/10
Terminal: Monospace/10

This supposed to be a default, I never changed it.
Comment 11 Caolan McNamara 2005-10-27 06:40:05 EDT
Sans is an alias of course, try 

> fc-match --verbose --sort "Sans"

to see what the matches are in order of preference

my "Sans" font is Luxi Sans, and trying "Bitstream Vera Sans" work as well
Comment 12 Pavel Rosenboim 2005-10-27 07:00:41 EDT
Sorry, I dont have an fc-match. Which package has it?
Comment 13 Pavel Rosenboim 2005-10-27 11:15:47 EDT
BTW, I just tried version 1.9.125 and final (2.0) release downloaded from OOo
site - both display things properly even when "use system font for user
interface" is selected.
Comment 14 Caolan McNamara 2005-12-05 06:15:41 EST
Created attachment 121845 [details]
fc4 update of 2.0.1-143.2.1
Comment 15 Caolan McNamara 2005-12-05 06:16:16 EST
Created attachment 121846 [details]
Comment 16 Caolan McNamara 2005-12-05 06:18:59 EST
Looks ok for me fc-4 with latest update for fc4 like the screenshot, if this
problem persists for you with >= 2.0.1-143.2.1 can you download the fc-match
attached here and run 

chmod u+x fc-match
./fc-match --verbose --sort "Sans"
Comment 17 Pavel Rosenboim 2005-12-05 13:40:16 EST
I tried version 2.0.1- I hope you meant this version, since I could
not find version 2.0.1-143.2.1 in either updates or updates-testing. This
version actually makes things worse: now the menu is garbled even when "Use
system fonts" is unchecked.
Comment 18 Pavel Rosenboim 2005-12-05 13:41:56 EST
Created attachment 121861 [details]
output of fc-match --verbose --sort "Sans"
Comment 19 Caolan McNamara 2005-12-06 03:02:20 EST
ok, that's good output from fc-match. I see that "Sans" matches

So I'd like to get that font for myself to see if that will reproduce things.
Where did it come from ?

> rpm -qf /usr/share/fonts/java/LucidaSansRegular.ttf

the sun jdk ?

Comment 20 Pavel Rosenboim 2005-12-06 03:07:25 EST

Yes, it's sun jdk.
Comment 21 Pavel Rosenboim 2005-12-06 03:28:38 EST
Created attachment 121897 [details]
bzipped font file
Comment 22 Pavel Rosenboim 2005-12-06 08:26:25 EST
2.0.1-143.2.1 from updates still has the problem.
Comment 23 Caolan McNamara 2005-12-06 08:42:45 EST
It could be hard to track this one down, Lucida Sans hasn't got the glyphs
needed, so glyph substitution occurs, for some reason it doesn't work for you,
but does for me. You have a large stack of fonts installed which I don't, so
presumably the problem is related to one of them.

I assume that typing the same letters in gedit and setting
edit->preferences->fonts->editor font to "Sans" does work ?
Comment 24 Pavel Rosenboim 2005-12-06 08:50:42 EST
Yes, it works.
I wonder what could be a difference between fedora build and OO.o build, since
version 2.0.1-143 (2.0.1 RC2) downloaded from www.openoffice.org does not have
this issue.
Comment 25 Caolan McNamara 2005-12-06 08:57:36 EST
Upstream doesn't have support for fontconfig glyph replacement, that's the
irony. Not using fontconfig means that upstream OOo cannot handle missing glyphs
as well as redhat OOo can (obviously in general, and not in this case) e.g. for
asian and indic text.
Comment 26 Caolan McNamara 2006-02-09 08:14:20 EST
It's real likely that this is part of the bug 180124 problem. Where multi pass
glyph substitution comes unstuck

*** This bug has been marked as a duplicate of 180124 ***

Note You need to log in before you can comment on or make changes to this bug.