Bug 180124 - second glyph substitution passes corrupted
second glyph substitution passes corrupted
Status: CLOSED DUPLICATE of bug 189761
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
: 171836 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 01:51 EST by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 05:25:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample file for illustrating this bug (11.53 KB, application/octet-stream)
2006-02-06 01:51 EST, Lawrence Lim
no flags Details
not sure I understand how to reproduce yet (239.70 KB, image/png)
2006-02-06 08:31 EST, Caolan McNamara
no flags Details
exact location of error (239.78 KB, image/png)
2006-02-07 02:37 EST, Lawrence Lim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 61835 None None None Never
OpenOffice.org 64743 None None None Never

  None (edit)
Description Lawrence Lim 2006-02-06 01:51:21 EST
Description of problem:
The env setting for this bug is on zh_CN.UTF-8 Desktop. oocalc was started from
gnome-terminal in en_US.UTF-8 locale.

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.0.1.1-5.2
scim-1.4.2-9
scim-pinyin-0.5.91-3.1

How reproducible:
Always

Steps to Reproduce:
1.in gdm log in with zh_CN locale (pre-req: scim and scim-pinyin installed)
2.start oocalc with sample opd file in en_US locale 
3.ctrl-space to activate SCIM
4. enter in between charcacters of line 3 of text for example
5. enter hongmao1
6. enter qiye1
  
Actual results:
text got scambled together

Expected results:
should be the same as input with oocalc in zh_CN locale

Additional info:
to verify, copy and paste the line of text into gedit, it should reveal the
difference clearly
Comment 1 Lawrence Lim 2006-02-06 01:51:21 EST
Created attachment 124243 [details]
sample file for illustrating this bug
Comment 2 Caolan McNamara 2006-02-06 08:31:12 EST
Created attachment 124255 [details]
not sure I understand how to reproduce yet

I opened the attachment with en_US locale but pinyan scim enabled and typed the
suggested letters into the 3rd line of zh_CN text and then the third line of
the document and here's what it looked like, and it looked ok. 

Am I misunderstanding, or not not reproducing ?
Comment 3 Lawrence Lim 2006-02-07 02:37:29 EST
Created attachment 124301 [details]
exact location of error

You are definitely on the right track. Noticed in the new screenshot, the new
input characters is very close to the original text in the document. Each
characters should be equally width. If you continue to input, characters may
overlaps as well.
Comment 4 Caolan McNamara 2006-02-08 13:53:33 EST
I've debugged enough of the problem now to see that it's a particularly nasty
one :-). It all depends on the order of the glyphs that are missing from the
font. Only the first pass of glyph substitution works correctly, follow up
passes don't get drawn in the right place or at all or some varient of that.
I'll knock up some demos that reproduce the problem in a pristine upstream
version and get some feedback on a solution.
Comment 5 Lawrence Lim 2006-02-09 00:35:59 EST
Noticed that oowriter also has the problem as well and only with en_US.
Comment 6 Caolan McNamara 2006-02-09 08:14:22 EST
*** Bug 171836 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2006-04-26 05:25:13 EDT
Our OOo font developer tells me I've fixed this with my patch for bug 189761,
i.e. http://www.openoffice.org/issues/show_bug.cgi?id=64743. A good day.

*** This bug has been marked as a duplicate of 189761 ***

Note You need to log in before you can comment on or make changes to this bug.