Bug 17184 - kernel won't boot on Athlon Model4 (previously known as tbird)
kernel won't boot on Athlon Model4 (previously known as tbird)
Status: CLOSED DUPLICATE of bug 16229
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Depends On:
  Show dependency treegraph
Reported: 2000-09-01 15:46 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-09-01 15:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-01 15:46:54 EDT
The first boot after installing, the kernel reports the Processor (AMD
Athlon Stepping 2) then attempts to deiable the p3 serial number and
oopses.  The change that needs to be made in the kernel is trivial. (The
4th entry of the AMD 6th generation table needs to be set to a non NULL
entry)  I have built a kernel that will get past that error, but cannot
mount the root raid1.
What is the correct way to create a boot disk that will boot a raided root
on another machine?
I have the partition layouts to the sector on the drives if I need them.

Sorry I don't have a patch but I forgot to backup /arch/i386/kernel/setup.c
the change needs to be made on line 818.
Comment 1 Michael K. Johnson 2000-09-01 16:36:25 EDT
Workaround in 16229, fixed in errata kernel.

*** This bug has been marked as a duplicate of 16229 ***

Note You need to log in before you can comment on or make changes to this bug.