Bug 17192 - man crashes after upgrade to man-1.5h1-2.5.x
man crashes after upgrade to man-1.5h1-2.5.x
Status: CLOSED DUPLICATE of bug 17187
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Depends On:
  Show dependency treegraph
Reported: 2000-09-02 18:25 EDT by mal
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-09-06 03:21:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mal 2000-09-02 18:25:04 EDT
After applying all updates
from RedHat 5.2
man crashes on avery request
man man
Segmentation fault
gdb man
GNU gdb with Linux/x86 hardware watchpoint and FPU support
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
welcome to change it and/or distribute copies of it under certain
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) run man
Starting program: /usr/bin/man man

Program received signal SIGSEGV, Segmentation fault.
0x4002b434 in __open_catalog (catalog=0x80624d0, with_path=1)
    at open_catalog.c:91
open_catalog.c:91: No such file or directory.
(gdb) bt
#0  0x4002b434 in __open_catalog (catalog=0x80624d0, with_path=1)
    at open_catalog.c:91
#1  0x4002b157 in catgets (catalog_desc=0x80624d0, set=2, message=40, 
    string=0x804e983 "") at catgets.c:137
#2  0x804d584 in _start ()
#3  0x804d5e0 in _start ()
#4  0x804a1c2 in _start ()
#5  0x804a43b in _start ()
#6  0x804a540 in _start ()
#7  0x804a859 in _start ()
#8  0x804b087 in _start ()
Comment 1 mal 2000-09-02 18:32:54 EDT
after downgrade to
man works OK
Comment 2 mal 2000-09-02 18:34:49 EDT
In addition:
some files in new man package in the directory
have rw-rw-rw permissions
what is incorrect.
Comment 3 Need Real Name 2000-09-04 15:18:34 EDT
A backtrace of this problem, which I am also experiencing, with a version of 
this RPM built with debugging symbols, shows that we are crashing with glibc 
(!).  Specifically, in __open_catalog(), which is called by catgets().  Here's 
the trace:

#0  0x40029434 in __open_catalog (catalog=0x80888b8, with_path=1)
    at open_catalog.c:91
#1  0x40029157 in catgets (catalog_desc=0x80888b8, set=2, message=40, 
    string=0x804e983 "") at catgets.c:137
#2  0x804d584 in getmsg (n=40) at gripes.c:67
#3  0x804d5e0 in gripe (n=40) at gripes.c:85
#4  0x804a1c2 in make_cat_file (path=0x8088668 "/usr/man", 
    man_file=0x80886c8 "/usr/man/man1/man.1.gz", 
    cat_file=0x8088738 "/var/catman/cat1/man.1.gz") at man.c:694
#5  0x804a43b in make_and_display_cat_file (path=0x8088668 "/usr/man", 
    man_file=0x80886c8 "/usr/man/man1/man.1.gz") at man.c:783
#6  0x804a540 in format_and_display (
    man_file=0x8088678 "/usr/man/man1/man.1.gz") at man.c:844
#7  0x804a859 in man (name=0xbffffe39 "man", section=0x0) at man.c:961
#8  0x804b087 in main (argc=2, argv=0xbffffd24) at man.c:1177
Comment 4 Need Real Name 2000-09-05 04:57:47 EDT
This behaviour seems to have been triggered by upgrade to glibc. Everything 
worked OK untill yesterday with glibc-2.0.7-19. However, after upgrade to 
current glibc-2.0.7-29, man doesn't work anymore. That kinda sucks.
Comment 5 Need Real Name 2000-09-06 03:21:51 EDT
This bug is a duplicate of bug 17187. Hello, maintainer, please mark it as such.
Comment 6 Jeff Johnson 2000-10-06 18:18:18 EDT

*** This bug has been marked as a duplicate of 17187 ***

Note You need to log in before you can comment on or make changes to this bug.