Bug 1719477 - clean up protocol specified in pom.xml for various jenkins plugin builds
Summary: clean up protocol specified in pom.xml for various jenkins plugin builds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.11.z
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks: 1719795 1723535
TreeView+ depends on / blocked
 
Reported: 2019-06-11 22:29 UTC by Gabe Montero
Modified: 2019-07-23 19:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: the pom.xml of some of the openshift jenkins plugins had http:// references instead of https:// references for some of its build time dependencies Consequence: when building the plugins, dependency downloads would occur over http instead of https Fix: the pom.xml references were corrected Result: any dependency downloads during building of the plugins now always occur over https
Clone Of:
: 1719795 1723535 (view as bug list)
Environment:
Last Closed: 2019-07-23 19:56:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1753 None None None 2019-07-23 19:56:33 UTC

Description Gabe Montero 2019-06-11 22:29:52 UTC

Comment 1 Gabe Montero 2019-06-11 23:24:56 UTC
PR https://github.com/openshift/jenkins/pull/868 is up

Once that merges, I'll post the ART request link for updating the plugin RPM

Comment 2 Gabe Montero 2019-06-12 14:40:44 UTC
PR has merged .... ART req for RPM update https://jira.coreos.com/browse/ART-671

Comment 5 XiuJuan Wang 2019-07-10 08:20:50 UTC
Do regression with pipeline build, login with openshift oauth, sync builds between openshift, no issue found.
Test with openshift3/jenkins-2-rhel7:v3.11(v3.11.128-2)

Comment 7 errata-xmlrpc 2019-07-23 19:56:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1753


Note You need to log in before you can comment on or make changes to this bug.