Bug 171948 - kernel boots but doesnt detect drives when using mptbase/mptscsih modules
kernel boots but doesnt detect drives when using mptbase/mptscsih modules
Status: CLOSED DUPLICATE of bug 169610
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 20:49 EDT by Erik A. Espinoza
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 00:43:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik A. Espinoza 2005-10-27 20:49:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Description of problem:
I am running fc4 x86_64 on a Sun v40z. Once installed I ran 'yum -y update', which installed kernel-smp-2.6.13-1.1532_FC4 and kernel-2.6.13-1.1532_FC4. Upon reboot, the machine did not recognize any of the drives connected to the LSI Fusion Card, which caused an init panic because it couldn't find the disk.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1532_FC4, kernel-smp-2.6.13-1.1532_FC4

How reproducible:
Always

Steps to Reproduce:
1. install fc4 on machine with LSI Fusion Card
2. boot up
3. yum -y update
4. reboot
5. crash

Actual Results:  System crashed

Expected Results:  System boots properly

Additional info:

I rebuilt a kernel using the kernel source and configs doing the following:

# rpm -i kernel-2.6.13-1.1532_FC4.src.rpm
# cd /usr/src/redhat/SPECS
# rpmbuild -bp kernel-2.6.spec
# cd ../BUILD/kernel-2.6.13/linux-2.6.13
# cp configs/kernel-2.6.13-x86_64-smp.config .config
# make menuconfig  <== Below is a diff of the changes made
# make bzImage ; make modules ; make modules_install
# mkinitrd --builtin=mptbase --builtin=mptscsih /boot/initrd-2.6.13-prep.img 2.6.13-prep
# cp arch/x86_64/boot/bzImage /boot/vmlinuz-2.6.13-prep

I modified the grub and rebooted, the system boots up perfectly. For some reason building the drivers into the kernel works correctly. Using the modules does not. I had also tried to rebuild the initrd with --preload for the scsi modules with the fedora rpm, but that also failed.

======================
CHANGES to the config:
======================
--- configs/kernel-2.6.13-x86_64-smp.config     2005-10-26 14:57:31.000000000 -0700
+++ .config     2005-10-26 15:25:01.000000000 -0700
@@ -1,8 +1,7 @@
-# x86_64
 #
 # Automatically generated make config: don't edit
-# Linux kernel version: 2.6.13.4
-# Wed Oct 26 14:57:31 2005
+# Linux kernel version: 2.6.13-TEST
+# Wed Oct 26 15:25:01 2005
 #
 CONFIG_X86_64=y
 CONFIG_64BIT=y
@@ -906,7 +905,7 @@
 #
 # SCSI device support
 #
-CONFIG_SCSI=m
+CONFIG_SCSI=y
 CONFIG_SCSI_PROC_FS=y

 #
@@ -996,7 +995,7 @@
 # CONFIG_SCSI_QLOGIC_FC is not set
 CONFIG_SCSI_QLOGIC_1280=m
 CONFIG_SCSI_QLOGIC_1280_1040=y
-CONFIG_SCSI_QLA2XXX=m
+CONFIG_SCSI_QLA2XXX=y
 CONFIG_SCSI_QLA21XX=m
 CONFIG_SCSI_QLA22XX=m
 CONFIG_SCSI_QLA2300=m
@@ -1040,11 +1039,11 @@
 # Fusion MPT device support
 #
 CONFIG_FUSION=y
-CONFIG_FUSION_SPI=m
-CONFIG_FUSION_FC=m
+CONFIG_FUSION_SPI=y
+CONFIG_FUSION_FC=y
 CONFIG_FUSION_MAX_SGE=40
-CONFIG_FUSION_CTL=m
-CONFIG_FUSION_LAN=m
+CONFIG_FUSION_CTL=y
+CONFIG_FUSION_LAN=y

 #
 # IEEE 1394 (FireWire) support
Comment 1 Dave Jones 2005-10-28 00:43:10 EDT

*** This bug has been marked as a duplicate of 169610 ***

Note You need to log in before you can comment on or make changes to this bug.