Bug 169610 - (FC4_FUSION) 2.6.13 mpt fusion driver changes break existing setup.
2.6.13 mpt fusion driver changes break existing setup.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 169611 169689 169957 170119 171274 171592 171671 171686 171948 172107 173145 174698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 03:55 EDT by Laurent NEGRIER
Modified: 2015-01-04 17:22 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 08:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Laurent NEGRIER 2005-09-30 03:55:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Description of problem:
at boot ther is a kernel panic because the file /dev/console was not found !!

Version-Release number of selected component (if applicable):
kernel 2.6.13-1.1526_FC4smp

How reproducible:
Always

Steps to Reproduce:
1. update to the 2.6.13-1.1526_FC4smp kernel
2. reboot
3. crash
  

Additional info:
Comment 1 Dave Jones 2005-09-30 04:09:20 EDT
*** Bug 169611 has been marked as a duplicate of this bug. ***
Comment 2 Laurent NEGRIER 2005-09-30 04:33:01 EDT
the bug is for a dell power edge 1850 server width Bi-Xeon and scsi
it's ok for a mother bord Asus A8B-SLI deluxe with an AMD Athlon proc and sata
Comment 3 Dave Jones 2005-09-30 05:06:13 EDT
can you paste the contents of /etc/modprobe.conf here please ?
Comment 4 Laurent NEGRIER 2005-09-30 05:11:23 EDT
#cat /etc/modprobe.conf

alias eth0 e1000
alias eth1 e1000
alias scsi_hostadapter mptbase
alias scsi_hostadapter1 mptscsih
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

Comment 5 Dave Jones 2005-09-30 05:54:03 EDT
upstream split this driver up. you'll need to do this..

1. rpm -e kernel-2.6.12-1.1528_FC4

2. edit your /etc/modprobe.conf
delete "alias scsi_hostadapter1 mptscsih"

3. If you have a scsi drive/controller, add
alias scsi_hostadapter1 mptspi

If it's fibre-channel, add
alias scsi_hostadapter1 mptfc

4. reinstall the new kernel, and it'll build a correct initrd.

Give that a try, and let me know how it works out.
Comment 6 Laurent NEGRIER 2005-09-30 07:16:32 EDT
yes, it boots ! all is right now. thanks
Comment 7 Dave Jones 2005-10-02 17:02:40 EDT
*** Bug 169689 has been marked as a duplicate of this bug. ***
Comment 8 Dave Jones 2005-10-06 03:45:19 EDT
*** Bug 169957 has been marked as a duplicate of this bug. ***
Comment 9 Need Real Name 2005-10-24 18:29:43 EDT
Had the same problem with FC4 on a VMware Workstation 5 instance (Guest OS).  I
made the suggested changes:

 1. Removed the kernel package
 2. Changed /etc/modprobe.conf:

     From -> alias scsi_hostadapter1 mptscsih
     To   -> alias  scsi_hostadapter1 mptspi

 3. Reinstalled kernel package
 4. Rebooted

Works great now in FC4
Comment 10 Dave Jones 2005-10-25 04:46:52 EDT
*** Bug 171671 has been marked as a duplicate of this bug. ***
Comment 11 Dave Jones 2005-10-27 20:07:50 EDT
*** Bug 171686 has been marked as a duplicate of this bug. ***
Comment 12 Dave Jones 2005-10-27 20:12:06 EDT
*** Bug 171592 has been marked as a duplicate of this bug. ***
Comment 13 Dave Jones 2005-10-28 00:43:30 EDT
*** Bug 171948 has been marked as a duplicate of this bug. ***
Comment 14 Ian Turley 2005-10-29 05:56:00 EDT
Worked for me - thx
Comment 15 Dave Jones 2005-11-04 19:53:46 EST
*** Bug 172107 has been marked as a duplicate of this bug. ***
Comment 16 Dave Jones 2005-11-05 00:31:22 EST
*** Bug 171274 has been marked as a duplicate of this bug. ***
Comment 17 Dave Jones 2005-11-05 02:36:53 EST
*** Bug 170119 has been marked as a duplicate of this bug. ***
Comment 18 Dave Jones 2005-11-05 03:13:42 EST
*** Bug 171733 has been marked as a duplicate of this bug. ***
Comment 19 Dave Jones 2005-11-14 14:42:19 EST
*** Bug 173145 has been marked as a duplicate of this bug. ***
Comment 20 Dave Jones 2005-12-02 00:13:53 EST
*** Bug 174698 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.